Add openssl libraries to the configure script for eap submodules (#1734)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jun 2007 17:50:21 +0000 (17:50 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jun 2007 17:50:21 +0000 (17:50 +0000)
SVN-Revision: 7456

net/freeradius/Makefile

index 02d5bc9f6058f52623511e4dee91f6c52a0a6709..6ccfe2be977bcb38f33d78a8939949c51a4c0bfc 100644 (file)
@@ -267,18 +267,21 @@ endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-peap),)
   PKG_CONFIGURE_ARGS+= --with-rlm_eap_peap
+  PKG_CONFIGURE_LIBS+= -lcrypto -lssl
 else
   PKG_CONFIGURE_ARGS+= --without-rlm_eap_peap
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-tls),)
   PKG_CONFIGURE_ARGS+= --with-rlm_eap_tls
+  PKG_CONFIGURE_LIBS+= -lcrypto -lssl
 else
   PKG_CONFIGURE_ARGS+= --without-rlm_eap_tls
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-ttls),)
   PKG_CONFIGURE_ARGS+= --with-rlm_eap_ttls
+  PKG_CONFIGURE_LIBS+= -lcrypto -lssl
 else
   PKG_CONFIGURE_ARGS+= --without-rlm_eap_ttls
 endif