[packages] motion: update to v3.2.11.1, add dependency on libpthread, cleanup
authorNicolas Thill <nico@openwrt.org>
Tue, 6 Oct 2009 03:02:53 +0000 (03:02 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 6 Oct 2009 03:02:53 +0000 (03:02 +0000)
SVN-Revision: 17944

multimedia/motion/Makefile
multimedia/motion/patches/001-ffmpeg.patch [deleted file]
multimedia/motion/patches/002-honor_cppflags.patch

index 77abff36e039ed5d558a40ea0aac07c9cd4527ae..98b4b5a2e912d70fe56a8aaa68ade5d037a94912 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=3.2.10.1
+PKG_VERSION:=3.2.11.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
                @SF/motion
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
                @SF/motion
-PKG_MD5SUM:=5ffdc958313345c69d3e0d5ec5c013cd
+PKG_MD5SUM:=4e729f129d8f9b9abaed5121c3cd0037
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/motion
   SECTION:=multimedia
   CATEGORY:=Multimedia
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/motion
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg
+  DEPENDS:=+libjpeg +libpthread
   TITLE:=webcam motion sensing and logging
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
   TITLE:=webcam motion sensing and logging
   URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
 endef
@@ -30,14 +30,11 @@ define Package/motion/conffiles
 /etc/motion.conf
 endef
 
 /etc/motion.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-ffmpeg \
-               --without-jpeg-mmx \
-               --without-mysql \
-               --without-pgsql \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --without-ffmpeg \
+       --without-jpeg-mmx \
+       --without-mysql \
+       --without-pgsql \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
diff --git a/multimedia/motion/patches/001-ffmpeg.patch b/multimedia/motion/patches/001-ffmpeg.patch
deleted file mode 100644 (file)
index 9c04e13..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/motion.c
-+++ b/motion.c
-@@ -1611,6 +1611,7 @@
-                * httpd-control snaps are always enabled.
-                */
-+#ifdef HAVE_FFMPEG
-               /* time_current_frame is used both for snapshot and timelapse features */
-               time_current_frame = cnt->currenttime;
-@@ -1620,7 +1621,7 @@
-                       event(cnt, EVENT_IMAGE_SNAPSHOT, cnt->current_image->image, NULL, NULL, &cnt->current_image->timestamp_tm);
-                       cnt->snapshot = 0;
-               }
--
-+#endif /* HAVE_FFMPEG */
-       /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
-@@ -1695,9 +1696,9 @@
-                       event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
-+              time_last_frame = time_current_frame;
- #endif /* HAVE_FFMPEG */
--              time_last_frame = time_current_frame;
-       /***** MOTION LOOP - VIDEO LOOPBACK SECTION *****/
index 81ae26a64144b56901cba44d2582c1eaaee9346c..ac10f1e9c787ae0f23e0915c44c41fa7b0bcad7e 100644 (file)
@@ -1,14 +1,14 @@
 --- a/Makefile.in
 +++ b/Makefile.in
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -32,6 +32,7 @@
+@@ -31,6 +31,7 @@ examplesdir = $(datadir)/@PACKAGE_NAME@-
+ # install.                                                                     #
  ################################################################################
  ################################################################################
- CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\"  \
-              -Dsysconfdir=\"$(sysconfdir)\" -Ddocdir=\"$(docdir)\"
+ CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" -Dsysconfdir=\"$(sysconfdir)\" 
 +CPPFLAGS     = @CPPFLAGS@
  LDFLAGS      = @LDFLAGS@
  LIBS         = @LIBS@ 
  VIDEO_OBJ    = @VIDEO@
 +CPPFLAGS     = @CPPFLAGS@
  LDFLAGS      = @LDFLAGS@
  LIBS         = @LIBS@ 
  VIDEO_OBJ    = @VIDEO@
-@@ -119,7 +120,7 @@
+@@ -118,7 +119,7 @@ endif
  ################################################################################
  $(DEPEND_FILE): *.h $(SRC)
        @echo "Generating dependencies, please wait..."
  ################################################################################
  $(DEPEND_FILE): *.h $(SRC)
        @echo "Generating dependencies, please wait..."