batman: cleanup and honor copts, updated to 0.2-rv478 as well
authorTim Yardley <lst@openwrt.org>
Tue, 31 Jul 2007 19:42:13 +0000 (19:42 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 31 Jul 2007 19:42:13 +0000 (19:42 +0000)
SVN-Revision: 8281

net/batman/Makefile
net/batman/patches/100-makefile.patch

index 967fceddb3a40737ca954f94b44045a0a83f3bda..1bfd76c57aa46814e3ceb6dc39bd0359d418aa0d 100644 (file)
@@ -8,15 +8,15 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=batman-III
-PKG_VERSION:=0.2.0a
+PKG_NAME:=batmand
+PKG_VERSION:=0.2-rv478
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tbz2
-PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman
-PKG_MD5SUM:=d5ac8329633590ed072a6b7ecccacf0b
-PKG_CAT:=bzcat
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)_sources
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_sources.tgz
+PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman/stable/sources/
+PKG_MD5SUM:=b00ad9603e32c85224d5b19f99126ddf
+PKG_CAT:=zcat
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -33,18 +33,15 @@ endef
 define Build/Configure
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C "$(PKG_BUILD_DIR)" \
-               $(TARGET_CONFIGURE_OPTS) \
-               NODEBUG=1 \
-               OFLAGS="$(TARGET_CFLAGS)" \
-               UNAME="Linux" \
-               INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-               STRIP="/bin/true" \
-               batmand install
-endef
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       CCFLAGS="$(TARGET_CFLAGS)" \
+       OFLAGS="$(TARGET_CFLAGS)" \
+       NODEBUG=1 \
+       UNAME="Linux" \
+       INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+       STRIP="/bin/true" \
+       batmand install
 
 define Package/batman/install
        $(INSTALL_DIR) $(1)/usr/sbin
index b96541f74205b625db8f35b0d5ffb1cb8f4320ac..a46a59475085b2fa07575b5180bd8a0b59de8a01 100644 (file)
@@ -1,18 +1,20 @@
---- batman-III-0.2.0a.old/Makefile     2007-02-28 15:41:11.000000000 +0100
-+++ batman-III-0.2.0a/Makefile 2007-02-28 15:42:02.000000000 +0100
-@@ -27,6 +27,7 @@
- CFLAGS =              -Wall -O0 -g3
- LDFLAGS =             -lpthread
- #LDFLAGS =            -static -lpthread
-+SBINDIR =      $(INSTALL_PREFIX)/usr/sbin
+Index: batmand_0.2-rv478_sources/Makefile
+===================================================================
+--- batmand_0.2-rv478_sources.orig/Makefile    2007-07-31 14:26:18.000000000 -0500
++++ batmand_0.2-rv478_sources/Makefile 2007-07-31 14:28:43.000000000 -0500
+@@ -21,6 +21,7 @@
+ CFLAGS =              -Wall -O1 -g3 -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA
+ STRIP=                        strip
+ LDFLAGS =             -lpthread -static
++SBINDIR =             $(INSTALL_PREFIX)/usr/sbin
  
- UNAME=$(shell uname)
+ CFLAGS_MIPS = -Wall -O1 -g3
+ LDFLAGS_MIPS =        -lpthread
+@@ -264,3 +265,7 @@
  
-@@ -67,3 +68,7 @@
- clean:
-               rm -f batmand batmand-mips* *.o *~
+ clean-long:
+               rm -rf batmand_*
 +
 +install:
 +              mkdir -p $(SBINDIR)
-+              install -m 755 batmand $(SBINDIR)
++              install -m 0755 batmand $(SBINDIR)