switch ctorrent to using the build variants infrastructure
authorPeter Wagner <​tripolar@gmx.at>
Sun, 28 Feb 2010 17:32:15 +0000 (17:32 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Sun, 28 Feb 2010 17:32:15 +0000 (17:32 +0000)
* ctorrent is linked to openssl
* ctorrent-nossl uses builtin SHA-1

SVN-Revision: 19914

net/ctorrent/Makefile

index 4c595fee6f64a065e20080069f3f21259dbde198..8b2de4b1383a8acdd5e7cd39b5ccc306c3121781 100644 (file)
@@ -9,13 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ctorrent
 PKG_VERSION:=dnh3.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/dtorrent \
        http://www.rahul.net/dholmes/ctorrent/
 PKG_MD5SUM:=59b23dd05ff70791cd6449effa7fc3b6
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ctorrent/Default
@@ -35,64 +37,46 @@ endef
 
 define Package/ctorrent
 $(call Package/ctorrent/Default)
-  TITLE+= (with builtin SHA-1 support)
+  TITLE+= (with OpenSSL support)
+  VARIANT:=ssl
 endef
 
 define Package/ctorrent/description
 $(call Package/ctorrent/Default/description)
- This package is built with builtin (Steve Reid's public-domain) SHA-1 support
+ This package is built with OpenSSL support.
 endef
 
-define Package/ctorrent-openssl
+define Package/ctorrent-nossl
 $(call Package/ctorrent/Default)
-  DEPENDS+= +libopenssl
-  TITLE+= (with OpenSSL support)
+  TITLE+= (with builtin SHA-1)
+  VARIANT:=nossl
 endef
 
-define Package/ctorrent-openssl/description
+define Package/ctorrent-nossl/description
 $(call Package/ctorrent/Default/description)
- This package is built with OpenSSL support.
+ This package is built with builtin (Steve Reid's public-domain) SHA-1 support
 endef
 
-define Build/Template
-
-$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
-       -$(MAKE) -C $(PKG_BUILD_DIR) clean
-       $(call Build/Configure/Default,$(3))
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       ( cd $(PKG_BUILD_DIR); mv -f $(PKG_NAME) $(PKG_NAME)-$(2) )
-       touch $$@
+CONFIGURE_VARS += \
+       CXX="g++-uc" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" 
 
-$(STAMP_BUILT): $(STAMP_BUILT)-$(2)
+ifeq ($(BUILD_VARIANT),ssl)
+       CONFIGURE_ARGS += \
+               --with-ssl="$(STAGING_DIR)/usr"
+endif
 
-define Package/$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME)-$(2) $$(1)/usr/bin/$(PKG_NAME)
-endef
+ifeq ($(BUILD_VARIANT),nossl)
+       CONFIGURE_ARGS += \
+               --with-ssl=no
+endif
 
+define Package/ctorrent/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/$(PKG_NAME)
 endef
 
-CONFIGURE_VARS += \
-       CXX="g++-uc" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
-
-ifneq ($(SDK)$(CONFIG_PACKAGE_ctorrent),)
-  define Build/with-ssl
-    $(call Build/Template,ctorrent,with-ssl, \
-       --with-ssl=no \
-    )
-  endef
-endif
-$(eval $(Build/with-ssl))
-
-ifneq ($(SDK)$(CONFIG_PACKAGE_ctorrent-openssl),)
-  define Build/with-openssl
-    $(call Build/Template,ctorrent-openssl,with-openssl, \
-       --with-ssl="$(STAGING_DIR)/usr" \
-    )  
-  endef
-endif
-$(eval $(Build/with-openssl))
+Package/ctorrent-nossl/install = $(Package/ctorrent/install)
 
 $(eval $(call BuildPackage,ctorrent))
-$(eval $(call BuildPackage,ctorrent-openssl))
+$(eval $(call BuildPackage,ctorrent-nossl))