[package] update ser2net to 2.6 (#5901)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 26 Sep 2009 12:20:11 +0000 (12:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 26 Sep 2009 12:20:11 +0000 (12:20 +0000)
SVN-Revision: 17736

net/ser2net/Makefile

index 6027051ed5ac4d73ef863ddec0e1afb4bb67736f..29746de46394c1042ef25a122ccbec2725e0cacc 100644 (file)
@@ -4,17 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-       
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ser2net
-PKG_VERSION:=2.5
+PKG_VERSION:=2.6
 PKG_RELEASE:=1
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ser2net
-PKG_MD5SUM:=c11f36ff2e4c523be7b282f2f6d03638
-       
+PKG_MD5SUM:=f53e067380ab31897923db665d044064
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ser2net
@@ -25,10 +25,10 @@ define Package/ser2net
 endef
 
 define Package/ser2net/description
-       This is ser2net, a program for allowing network connections to serial 
-       ports. See the man page for information about using the program. Note 
-       that ser2net supports RFC 2217 (remote control of serial port parameters), 
-       but you must have a complient client.
+  This is ser2net, a program for allowing network connections to serial ports.
+  See the man page for information about using the program. Note that ser2net
+  supports RFC 2217 (remote control of serial port parameters), but you must
+  have a complient client.
 endef
 
 define Package/ser2net/conffiles
@@ -37,17 +37,17 @@ endef
 
 # uses GNU configure
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
+
 define Package/ser2net/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ser2net $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(CP) $(PKG_BUILD_DIR)/ser2net.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ser2net.conf $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,ser2net))