[packages/libs/libxapian] stay compatible with Kamikaze 8.09
authorNicolas Thill <nico@openwrt.org>
Tue, 13 Jan 2009 02:00:27 +0000 (02:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 13 Jan 2009 02:00:27 +0000 (02:00 +0000)
SVN-Revision: 14008

libs/libxapian/Makefile

index 38e15d454b86bad29544e8d8d75deae485d8394c..9a11ea7b2c186887743dba3e07915f6ca29054fd 100644 (file)
@@ -58,9 +58,15 @@ define Build/InstallDev
        $(SED) 's,prefix=",prefix="$(STAGING_DIR),g' $(2)/bin/xapian-config
 
        #FIXME: Libtool should handle this
-       $(SED) \
+       if [ -f $(TOOLCHAIN_DIR)/usr/lib/libstdc++.la ]; then \
+         $(SED) \
                "s,$(STAGING_DIR)/usr/lib/libstdc++,$(TOOLCHAIN_DIR)/usr/lib/libstdc++,g" \
-               $(1)/usr/lib/libxapian.la
+               $(1)/usr/lib/libxapian.la ; \
+       else \
+         $(SED) \
+               "s,$(STAGING_DIR)/usr/lib/libstdc++,$(TOOLCHAIN_DIR)/lib/libstdc++,g" \
+               $(1)/usr/lib/libxapian.la ; \
+       fi
 endef
 
 define Package/libxapian/install