[package] remove uvc-streamer, mjpg-streamer does a better job
authorFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 11:10:07 +0000 (11:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 11:10:07 +0000 (11:10 +0000)
SVN-Revision: 17003

multimedia/uvc-streamer/Makefile
multimedia/uvc-streamer/files/uvc-streamer.config
multimedia/uvc-streamer/files/uvc-streamer.init

index 6dc4f10357854f234254c2fdd8114347d0c321f6..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,49 +0,0 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=uvc-streamer
-PKG_VERSION:=1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=uvc_streamer_2007_07_21_14.07.06.tgz
-PKG_SOURCE_URL:=http://naaa.de/programme/uvc_streamer/
-PKG_MD5SUM:=491473a25882c3e7250aeeb68e0ca689
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/uvc-streamer
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Linux-UVC streaming applicaton
-  DEPENDS:=@LINUX_2_6 +libpthread
-  URL:=http://www.naaa.de/uvc_streamer
-endef
-
-define Package/uvc-streamer/description
-       This package contains a streaming daemon for Linux-UVC based webcams
-endef
-
-MAKE_FLAGS += \
-       -C $(PKG_BUILD_DIR) \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       CC="$(TARGET_CC)" \
-       all
-
-define Package/uvc-streamer/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/uvc_stream $(1)/sbin/uvc_streamer
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
-endef
-
-$(eval $(call BuildPackage,uvc-streamer))
index 95d1e6a7be6296c8ddf7c6b3325a946f9403ef30..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,6 +0,0 @@
-config uvc-streamer
-       option device          '/dev/video0'
-       option resolution      '640x480'
-       option framespersecond '5'
-       option port            '8080'
-       option enabled         '1'
index b071d2c3f5139c200405839a6d0df9f2c1ec4912..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,51 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
-START=50
-
-SSD=start-stop-daemon
-NAME=uvc_streamer
-PIDF=/var/run/$NAME.pid
-PROG=/sbin/$NAME
-
-append_bool() {
-       local section="$1"
-       local option="$2"
-       local value="$3"
-       local _val
-       config_get_bool _val "$section" "$option" '0'
-       [ "$_val" -gt 0 ] && append args "$3"
-}
-
-append_string() {
-       local section="$1"
-       local option="$2"
-       local value="$3"
-       local _val
-       config_get _val "$section" "$option"
-       [ -n "$_val" ] && append args "$3 $_val"
-}
-
-start_service() {
-       local section="$1"
-       args=""
-       append_string "$section" device "-d"
-       append_string "$section" resolution "-r"
-       append_bool "$section" framespersecond "-f"
-       append_string "$section" port "-p"
-       config_get_bool "enabled" "$section" "enabled" '1'
-       [ "$enabled" -gt 0 ] && sleep 5s && $SSD -S -p $PIDF -q -x $PROG -- -b $args &
-}
-
-stop_service() {
-       $SSD -K -p $PIDF
-}
-
-start() {
-       config_load "uvc-streamer"
-       config_foreach start_service "uvc-streamer"
-}
-
-stop() {
-       config_load "uvc-streamer"
-       config_foreach stop_service "uvc-streamer"
-}