ar71xx: merge dev-ar9{13,34}x-wmac into dev-ar9xxx-wmac
authorGabor Juhos <juhosg@openwrt.org>
Mon, 11 Apr 2011 17:37:08 +0000 (17:37 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 11 Apr 2011 17:37:08 +0000 (17:37 +0000)
SVN-Revision: 26595

23 files changed:
target/linux/ar71xx/config-2.6.37
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar913x-wmac.c [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar913x-wmac.h [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar934x-wmac.c [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar934x-wmac.h [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar9xxx-wmac.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar9xxx-wmac.h [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-db120.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-615-c1.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w04nu.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w300nh.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-nbg460n.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tew-632brp.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wa901nd-v2.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr1043nd.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr941nd.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wnr2000.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wrt160nl.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wzr-hp-g300nh.c

index c39308e4a98bd455eabdd9d5ba3d8902e6ea005a..bbf76d564a1cba4321fcc6ddb9890bba34b830db 100644 (file)
@@ -4,8 +4,7 @@ CONFIG_AG71XX_AR8216_SUPPORT=y
 # CONFIG_AG71XX_DEBUG_FS is not set
 CONFIG_AR71XX_DEV_AP91_PCI=y
 CONFIG_AR71XX_DEV_AP94_PCI=y
-CONFIG_AR71XX_DEV_AR913X_WMAC=y
-CONFIG_AR71XX_DEV_AR934X_WMAC=y
+CONFIG_AR71XX_DEV_AR9XXX_WMAC=y
 CONFIG_AR71XX_DEV_DB120_PCI=y
 CONFIG_AR71XX_DEV_DSA=y
 CONFIG_AR71XX_DEV_GPIO_BUTTONS=y
index ea377def3ddf3486dd56ca526a36f217c3c9e54f..ec3d326eda8cf2ede70540048700e59e29bbcfbd 100644 (file)
@@ -5,7 +5,7 @@ menu "Atheros AR71xx machine selection"
 config AR71XX_MACH_AP81
        bool "Atheros AP81 board support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
@@ -13,7 +13,7 @@ config AR71XX_MACH_AP81
 
 config AR71XX_MACH_AP83
        bool "Atheros AP83 board support"
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
@@ -30,7 +30,7 @@ config AR71XX_MACH_AP96
 
 config AR71XX_MACH_DB120
        bool "Atheros DB120 board support"
-       select AR71XX_DEV_AR934X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_DB120_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
@@ -49,7 +49,7 @@ config AR71XX_MACH_DIR_600_A1
 config AR71XX_MACH_DIR_615_C1
        bool "D-Link DIR-615 rev. C1 support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_NVRAM
@@ -114,7 +114,7 @@ config AR71XX_MACH_AW_NR580
 
 config AR71XX_MACH_WZR_HP_G300NH
        bool "Buffalo WZR-HP-G300NH board support"
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
@@ -133,7 +133,7 @@ config AR71XX_MACH_WP543
 config AR71XX_MACH_WRT160NL
        bool "Linksys WRT160NL board support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
@@ -171,7 +171,7 @@ config AR71XX_MACH_WNDR3700
 config AR71XX_MACH_WNR2000
        bool "NETGEAR WNR2000 board support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        default n
@@ -179,7 +179,7 @@ config AR71XX_MACH_WNR2000
 config AR71XX_MACH_MZK_W04NU
        bool "Planex MZK-W04NU board support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
@@ -188,7 +188,7 @@ config AR71XX_MACH_MZK_W04NU
 config AR71XX_MACH_MZK_W300NH
        bool "Planex MZK-W300NH board support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        default n
@@ -196,7 +196,7 @@ config AR71XX_MACH_MZK_W300NH
 config AR71XX_MACH_NBG460N
        bool "Zyxel NBG460N/550N/550NH board support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        default n
@@ -221,7 +221,7 @@ config AR71XX_MACH_TL_WA901ND
 config AR71XX_MACH_TL_WA901ND_V2
        bool "TP-LINK TL-WA901ND v2 support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        default n
@@ -246,7 +246,7 @@ config AR71XX_MACH_TL_WR841N_V1
 config AR71XX_MACH_TL_WR941ND
        bool "TP-LINK TL-WR941ND support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_DSA
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
@@ -255,7 +255,7 @@ config AR71XX_MACH_TL_WR941ND
 config AR71XX_MACH_TL_WR1043ND
        bool "TP-LINK TL-WR1043ND support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
@@ -264,7 +264,7 @@ config AR71XX_MACH_TL_WR1043ND
 config AR71XX_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        select AR71XX_DEV_M25P80
-       select AR71XX_DEV_AR913X_WMAC
+       select AR71XX_DEV_AR9XXX_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_NVRAM
@@ -308,10 +308,7 @@ config AR71XX_DEV_AP94_PCI
        select AR71XX_PCI_ATH9K_FIXUP
        def_bool n
 
-config AR71XX_DEV_AR913X_WMAC
-       def_bool n
-
-config AR71XX_DEV_AR934X_WMAC
+config AR71XX_DEV_AR9XXX_WMAC
        def_bool n
 
 config AR71XX_DEV_DB120_PCI
index c9184b8e5e5d856c9462ed04f46a208d56092029..11e33dcef59f700896182e129df16fe5db1606c7 100644 (file)
@@ -15,8 +15,7 @@ obj-$(CONFIG_PCI)                     += pci.o
 
 obj-$(CONFIG_AR71XX_DEV_AP91_PCI)      += dev-ap91-pci.o
 obj-$(CONFIG_AR71XX_DEV_AP94_PCI)      += dev-ap94-pci.o
-obj-$(CONFIG_AR71XX_DEV_AR913X_WMAC)   += dev-ar913x-wmac.o
-obj-$(CONFIG_AR71XX_DEV_AR934X_WMAC)   += dev-ar934x-wmac.o
+obj-$(CONFIG_AR71XX_DEV_AR9XXX_WMAC)   += dev-ar9xxx-wmac.o
 obj-$(CONFIG_AR71XX_DEV_DB120_PCI)     += dev-db120-pci.o
 obj-$(CONFIG_AR71XX_DEV_DSA)           += dev-dsa.o
 obj-$(CONFIG_AR71XX_DEV_GPIO_BUTTONS)  += dev-gpio-buttons.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar913x-wmac.c b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar913x-wmac.c
deleted file mode 100644 (file)
index 7840ff9..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-/*
- *  Atheros AR913x SoC built-in WMAC device support
- *
- *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
- *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
- *
- *  Parts of this file are based on Atheros' 2.6.15 BSP
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/kernel.h>
-#include <linux/init.h>
-#include <linux/delay.h>
-#include <linux/etherdevice.h>
-#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
-
-#include <asm/mach-ar71xx/ar71xx.h>
-
-#include "dev-ar913x-wmac.h"
-
-static struct ath9k_platform_data ar913x_wmac_data = {
-       .led_pin = -1,
-};
-static char ar913x_wmac_mac[6];
-
-static struct resource ar913x_wmac_resources[] = {
-       {
-               .start  = AR91XX_WMAC_BASE,
-               .end    = AR91XX_WMAC_BASE + AR91XX_WMAC_SIZE - 1,
-               .flags  = IORESOURCE_MEM,
-       }, {
-               .start  = AR71XX_CPU_IRQ_IP2,
-               .end    = AR71XX_CPU_IRQ_IP2,
-               .flags  = IORESOURCE_IRQ,
-       },
-};
-
-static struct platform_device ar913x_wmac_device = {
-       .name           = "ath9k",
-       .id             = -1,
-       .resource       = ar913x_wmac_resources,
-       .num_resources  = ARRAY_SIZE(ar913x_wmac_resources),
-       .dev = {
-               .platform_data = &ar913x_wmac_data,
-       },
-};
-
-void __init ar913x_add_device_wmac(u8 *cal_data, u8 *mac_addr)
-{
-       if (cal_data)
-               memcpy(ar913x_wmac_data.eeprom_data, cal_data,
-                      sizeof(ar913x_wmac_data.eeprom_data));
-
-       if (mac_addr) {
-               memcpy(ar913x_wmac_mac, mac_addr, sizeof(ar913x_wmac_mac));
-               ar913x_wmac_data.macaddr = ar913x_wmac_mac;
-       }
-
-       ar71xx_device_stop(RESET_MODULE_AMBA2WMAC);
-       mdelay(10);
-
-       ar71xx_device_start(RESET_MODULE_AMBA2WMAC);
-       mdelay(10);
-
-       platform_device_register(&ar913x_wmac_device);
-}
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar913x-wmac.h b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar913x-wmac.h
deleted file mode 100644 (file)
index 72d8d72..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-/*
- *  Atheros AR913x SoC built-in WMAC device support
- *
- *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
- *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
- *
- *  Parts of this file are based on Atheros' 2.6.15 BSP
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#ifndef _AR71XX_DEV_AR913X_WMAC_H
-#define _AR71XX_DEV_AR913X_WMAC_H
-
-void ar913x_add_device_wmac(u8 *cal_data, u8 *mac_addr) __init;
-
-#endif /* _AR71XX_DEV_AR913X_WMAC_H */
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar934x-wmac.c b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar934x-wmac.c
deleted file mode 100644 (file)
index e7d550f..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-/*
- *  Atheros AR934x SoC built-in WMAC device support
- *
- *  Copyright (C) 2010-2011 Jaiganesh Narayanan <jnarayanan@atheros.com>
- *
- *  Parts of this file are based on Atheros 2.6.31 BSP
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/kernel.h>
-#include <linux/init.h>
-#include <linux/delay.h>
-#include <linux/etherdevice.h>
-#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
-
-#include <asm/mach-ar71xx/ar71xx.h>
-
-#include "dev-ar934x-wmac.h"
-
-static struct ath9k_platform_data ar934x_wmac_data = {
-       .led_pin = -1,
-};
-
-static u8 ar934x_wmac_mac[6];
-
-static struct resource ar934x_wmac_resources[] = {
-       {
-               .start  = AR934X_WMAC_BASE,
-               .end    = AR934X_WMAC_BASE + AR934X_WMAC_SIZE - 1,
-               .flags  = IORESOURCE_MEM,
-       }, {
-               .start  = AR71XX_CPU_IRQ_IP2,
-               .end    = AR71XX_CPU_IRQ_IP2,
-               .flags  = IORESOURCE_IRQ,
-       },
-};
-
-static struct platform_device ar934x_wmac_device = {
-       .name           = "ath9k",
-       .id             = -1,
-       .resource       = ar934x_wmac_resources,
-       .num_resources  = ARRAY_SIZE(ar934x_wmac_resources),
-       .dev = {
-               .platform_data = &ar934x_wmac_data,
-       },
-};
-
-void __init ar934x_add_device_wmac(u8 *cal_data, u8 *mac_addr)
-{
-       if (cal_data)
-               memcpy(ar934x_wmac_data.eeprom_data, cal_data,
-                      sizeof(ar934x_wmac_data.eeprom_data));
-
-       if (mac_addr) {
-               memcpy(ar934x_wmac_mac, mac_addr, sizeof(ar934x_wmac_mac));
-               ar934x_wmac_data.macaddr = ar934x_wmac_mac;
-       }
-
-       platform_device_register(&ar934x_wmac_device);
-}
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar934x-wmac.h b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar934x-wmac.h
deleted file mode 100644 (file)
index 3623000..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-/*
- *  Atheros AR934x SoC built-in WMAC device support
- *
- *  Copyright (C) 2010-2011 Jaiganesh Narayanan <jnarayanan@atheros.com>
- *
- *  Parts of this file are based on Atheros linux 2.6.31 BSP
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#ifndef _AR71XX_DEV_AR934X_WMAC_H
-#define _AR71XX_DEV_AR934X_WMAC_H
-
-void ar934x_add_device_wmac(u8 *cal_data, u8 *mac_addr) __init;
-
-#endif /* _AR71XX_DEV_AR934X_WMAC_H */
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar9xxx-wmac.c b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar9xxx-wmac.c
new file mode 100644 (file)
index 0000000..8a274ea
--- /dev/null
@@ -0,0 +1,98 @@
+/*
+ *  Atheros AR9XXX SoCs built-in WMAC device support
+ *
+ *  Copyright (C) 2010-2011 Jaiganesh Narayanan <jnarayanan@atheros.com>
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  Parts of this file are based on Atheros 2.6.15/2.6.31 BSP
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/delay.h>
+#include <linux/etherdevice.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "dev-ar9xxx-wmac.h"
+
+static struct ath9k_platform_data ar9xxx_wmac_data = {
+       .led_pin = -1,
+};
+static char ar9xxx_wmac_mac[6];
+
+static struct resource ar9xxx_wmac_resources[] = {
+       {
+               /* .start and .end fields are filled dynamically */
+               .flags  = IORESOURCE_MEM,
+       }, {
+               .start  = AR71XX_CPU_IRQ_IP2,
+               .end    = AR71XX_CPU_IRQ_IP2,
+               .flags  = IORESOURCE_IRQ,
+       },
+};
+
+static struct platform_device ar9xxx_wmac_device = {
+       .name           = "ath9k",
+       .id             = -1,
+       .resource       = ar9xxx_wmac_resources,
+       .num_resources  = ARRAY_SIZE(ar9xxx_wmac_resources),
+       .dev = {
+               .platform_data = &ar9xxx_wmac_data,
+       },
+};
+
+static void ar913x_wmac_init(void)
+{
+       ar71xx_device_stop(RESET_MODULE_AMBA2WMAC);
+       mdelay(10);
+
+       ar71xx_device_start(RESET_MODULE_AMBA2WMAC);
+       mdelay(10);
+
+       ar9xxx_wmac_resources[0].start = AR91XX_WMAC_BASE;
+       ar9xxx_wmac_resources[0].end = AR91XX_WMAC_BASE + AR91XX_WMAC_SIZE - 1;
+}
+
+static void ar934x_wmac_init(void)
+{
+       ar9xxx_wmac_resources[0].start = AR934X_WMAC_BASE;
+       ar9xxx_wmac_resources[0].end = AR934X_WMAC_BASE + AR934X_WMAC_SIZE - 1;
+}
+
+void __init ar9xxx_add_device_wmac(u8 *cal_data, u8 *mac_addr)
+{
+       switch (ar71xx_soc) {
+       case AR71XX_SOC_AR9130:
+       case AR71XX_SOC_AR9132:
+               ar913x_wmac_init();
+               break;
+
+       case AR71XX_SOC_AR9341:
+       case AR71XX_SOC_AR9342:
+       case AR71XX_SOC_AR9344:
+               ar934x_wmac_init();
+               break;
+
+       default:
+               BUG();
+       }
+
+       if (cal_data)
+               memcpy(ar9xxx_wmac_data.eeprom_data, cal_data,
+                      sizeof(ar9xxx_wmac_data.eeprom_data));
+
+       if (mac_addr) {
+               memcpy(ar9xxx_wmac_mac, mac_addr, sizeof(ar9xxx_wmac_mac));
+               ar9xxx_wmac_data.macaddr = ar9xxx_wmac_mac;
+       }
+
+       platform_device_register(&ar9xxx_wmac_device);
+}
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar9xxx-wmac.h b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-ar9xxx-wmac.h
new file mode 100644 (file)
index 0000000..4fa7ec2
--- /dev/null
@@ -0,0 +1,20 @@
+/*
+ *  Atheros AR9XXX SoCs built-in WMAC device support
+ *
+ *  Copyright (C) 2010-2011 Jaiganesh Narayanan <jnarayanan@atheros.com>
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  Parts of this file are based on Atheros 2.6.15/2.6.31 BSP
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#ifndef _AR71XX_DEV_AR9XXX_WMAC_H
+#define _AR71XX_DEV_AR9XXX_WMAC_H
+
+void ar9xxx_add_device_wmac(u8 *cal_data, u8 *mac_addr) __init;
+
+#endif /* _AR71XX_DEV_AR9XXX_WMAC_H */
index 2bf1e227b8dd294d4aa3598f5dc35665fd7375bf..a8d1818ae7def294fc3cda605d46ab0f57615dfe 100644 (file)
@@ -17,7 +17,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-usb.h"
@@ -135,7 +135,7 @@ static void __init ap81_setup(void)
                                        ARRAY_SIZE(ap81_gpio_buttons),
                                        ap81_gpio_buttons);
 
-       ar913x_add_device_wmac(eeprom, NULL);
+       ar9xxx_add_device_wmac(eeprom, NULL);
 }
 
 MIPS_MACHINE(AR71XX_MACH_AP81, "AP81", "Atheros AP81", ap81_setup);
index 721e0c3c0ee3bd8e418d8b1276def002e86359b7..964fac55d5c55f2bec3340e6a2913ec27aa425a7 100644 (file)
@@ -22,7 +22,7 @@
 
 #include "machtype.h"
 #include "devices.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-usb.h"
@@ -222,7 +222,7 @@ static void __init ap83_generic_setup(void)
 
        ar71xx_add_device_usb();
 
-       ar913x_add_device_wmac(eeprom, NULL);
+       ar9xxx_add_device_wmac(eeprom, NULL);
 
        platform_device_register(&ap83_flash_device);
 
index bc01f0d7105ad5ce5d52b1c60e05381367df347e..c6fb642454055de91732e7c733ba29379e653eb1 100644 (file)
@@ -19,7 +19,7 @@
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-usb.h"
-#include "dev-ar934x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-db120-pci.h"
 
 #define DB120_GPIO_LED_USB     11
@@ -124,7 +124,7 @@ static void __init db120_setup(void)
                                        ARRAY_SIZE(db120_gpio_buttons),
                                        db120_gpio_buttons);
 
-       ar934x_add_device_wmac(art + DB120_CALDATA_OFFSET,
+       ar9xxx_add_device_wmac(art + DB120_CALDATA_OFFSET,
                                art + DB120_WMAC_MAC_OFFSET);
 
        db120_pci_init();
index e98ccacaaa7394dce8f33c18987f937540f2f17d..e7431c5d2422a391ec9676d988113c647b241270 100644 (file)
@@ -17,7 +17,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "nvram.h"
@@ -167,7 +167,7 @@ static void __init dir_615c1_setup(void)
                                        ARRAY_SIZE(dir_615c1_gpio_buttons),
                                        dir_615c1_gpio_buttons);
 
-       ar913x_add_device_wmac(eeprom, wlan_mac);
+       ar9xxx_add_device_wmac(eeprom, wlan_mac);
 }
 
 MIPS_MACHINE(AR71XX_MACH_DIR_615_C1, "DIR-615-C1", "D-Link DIR-615 rev. C1",
index 829501e8f31cd419068cbac1640ef9d1f9a8015b..2f5d41618501c51f2cd11b8ac7521d743308eb9b 100644 (file)
@@ -15,7 +15,7 @@
 
 #include "machtype.h"
 #include "devices.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-m25p80.h"
@@ -158,7 +158,7 @@ static void __init mzk_w04nu_setup(void)
                                        mzk_w04nu_gpio_buttons);
        ar71xx_add_device_usb();
 
-       ar913x_add_device_wmac(eeprom, NULL);
+       ar9xxx_add_device_wmac(eeprom, NULL);
 }
 
 MIPS_MACHINE(AR71XX_MACH_MZK_W04NU, "MZK-W04NU", "Planex MZK-W04NU",
index b84038489c1423eb2a3a6ec61e99fe282b22d0dd..03ffe5e6868b639ddea47edd205becc32ea8fb86 100644 (file)
@@ -17,7 +17,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 
@@ -151,7 +151,7 @@ static void __init mzk_w300nh_setup(void)
        ar71xx_add_device_gpio_buttons(-1, MZK_W04NU_BUTTONS_POLL_INTERVAL,
                                        ARRAY_SIZE(mzk_w300nh_gpio_buttons),
                                        mzk_w300nh_gpio_buttons);
-       ar913x_add_device_wmac(eeprom, NULL);
+       ar9xxx_add_device_wmac(eeprom, NULL);
 }
 
 MIPS_MACHINE(AR71XX_MACH_MZK_W300NH, "MZK-W300NH", "Planex MZK-W300NH",
index a7f5adec7cd3b2307fcafc130f5e99aa9891c337..8f3b5208433183cde9801dbb63964d79ff8d35e0 100644 (file)
@@ -25,7 +25,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 
@@ -206,7 +206,7 @@ static void __init nbg460n_setup(void)
        /* register flash */
        ar71xx_add_device_m25p80(&nbg460n_flash_data);
 
-       ar913x_add_device_wmac(eeprom, mac);
+       ar9xxx_add_device_wmac(eeprom, mac);
 
        /* register RTC chip */
        nbg460n_i2c_init();
index 7bbec12668f6bfdf123a057ddb364de516ee8d7a..9816f0336a9aa96c29be39e983c649d0cb186cea 100644 (file)
@@ -17,7 +17,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "nvram.h"
@@ -143,7 +143,7 @@ static void __init tew_632brp_setup(void)
                                        ARRAY_SIZE(tew_632brp_gpio_buttons),
                                        tew_632brp_gpio_buttons);
 
-       ar913x_add_device_wmac(eeprom, wlan_mac);
+       ar9xxx_add_device_wmac(eeprom, wlan_mac);
 }
 
 MIPS_MACHINE(AR71XX_MACH_TEW_632BRP, "TEW-632BRP", "TRENDnet TEW-632BRP",
index aea83cfcaec85f58a9a26aba4bb2fcf058eeb158..72a8bd21f6ca566c932b553ca1745af31423c313 100644 (file)
@@ -20,7 +20,7 @@
 #include "dev-m25p80.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 
 #define TL_WA901ND_V2_GPIO_LED_QSS             4
 #define TL_WA901ND_V2_GPIO_LED_SYSTEM          2
@@ -124,7 +124,7 @@ static void __init tl_wa901nd_v2_setup(void)
                                        ARRAY_SIZE(tl_wa901nd_v2_gpio_buttons),
                                        tl_wa901nd_v2_gpio_buttons);
 
-        ar913x_add_device_wmac(eeprom, mac);
+        ar9xxx_add_device_wmac(eeprom, mac);
 }
 
 MIPS_MACHINE(AR71XX_MACH_TL_WA901ND_V2, "TL-WA901ND-v2",
index 57948b35627441854582defe970b4649dc63ec85..e4de9d50c1474d88c273ccea9d5b726b9e66970b 100644 (file)
@@ -17,7 +17,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-usb.h"
@@ -148,7 +148,7 @@ static void __init tl_wr1043nd_setup(void)
                                        ARRAY_SIZE(tl_wr1043nd_gpio_buttons),
                                        tl_wr1043nd_gpio_buttons);
 
-       ar913x_add_device_wmac(eeprom, mac);
+       ar9xxx_add_device_wmac(eeprom, mac);
 }
 
 MIPS_MACHINE(AR71XX_MACH_TL_WR1043ND, "TL-WR1043ND", "TP-LINK TL-WR1043ND",
index 4f71df66e9aceddea657a49795781ddf15272402..c0085e5739091ad8cc912a871a734e0afcdcfabb 100644 (file)
@@ -17,7 +17,7 @@
 #include "devices.h"
 #include "dev-dsa.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 
@@ -139,7 +139,7 @@ static void __init tl_wr941nd_setup(void)
        ar71xx_add_device_gpio_buttons(-1, TL_WR941ND_BUTTONS_POLL_INTERVAL,
                                        ARRAY_SIZE(tl_wr941nd_gpio_buttons),
                                        tl_wr941nd_gpio_buttons);
-       ar913x_add_device_wmac(eeprom, mac);
+       ar9xxx_add_device_wmac(eeprom, mac);
 }
 
 MIPS_MACHINE(AR71XX_MACH_TL_WR941ND, "TL-WR941ND", "TP-LINK TL-WR941ND",
index f4171b01e225988fafc7e698e7a7a1b93ea15c6e..24cf477a19e6cedde847b02d8b6f1a4fec7ad8d3 100644 (file)
@@ -18,7 +18,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 
@@ -143,7 +143,7 @@ static void __init wnr2000_setup(void)
                                        wnr2000_gpio_buttons);
 
 
-       ar913x_add_device_wmac(eeprom, NULL);
+       ar9xxx_add_device_wmac(eeprom, NULL);
 }
 
 MIPS_MACHINE(AR71XX_MACH_WNR2000, "WNR2000", "NETGEAR WNR2000", wnr2000_setup);
index b4c822ddfa232364c4eb086697757af9ffcf05df..72dece80ad9ed8a8d7585306c0910252c3459b69 100644 (file)
@@ -16,7 +16,7 @@
 #include "machtype.h"
 #include "devices.h"
 #include "dev-m25p80.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-usb.h"
@@ -143,9 +143,9 @@ static void __init wrt160nl_setup(void)
 
        if (nvram_parse_mac_addr(nvram, WRT160NL_NVRAM_SIZE,
                                 "wl0_hwaddr=", mac) == 0)
-               ar913x_add_device_wmac(eeprom, mac);
+               ar9xxx_add_device_wmac(eeprom, mac);
        else
-               ar913x_add_device_wmac(eeprom, NULL);
+               ar9xxx_add_device_wmac(eeprom, NULL);
 
        ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(wrt160nl_leds_gpio),
                                        wrt160nl_leds_gpio);
index ac871003afb2936467e8cf20bfdbc1ad7ac3d22e..383d87b5f4b42fd8e5a9ea51244d20cfbf7b26e9 100644 (file)
@@ -20,7 +20,7 @@
 
 #include "machtype.h"
 #include "devices.h"
-#include "dev-ar913x-wmac.h"
+#include "dev-ar9xxx-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-usb.h"
@@ -247,7 +247,7 @@ static void __init wzrhpg300nh_setup(void)
        ar71xx_add_device_eth(1);
 
        ar71xx_add_device_usb();
-       ar913x_add_device_wmac(eeprom, NULL);
+       ar9xxx_add_device_wmac(eeprom, NULL);
 
        platform_device_register(&wzrhpg300nh_74hc153_device);
        platform_device_register(&wzrhpg300nh_flash_device);