work around permission problems in the file package - fixes avr32 compile error
authorFelix Fietkau <nbd@openwrt.org>
Wed, 8 Oct 2008 16:31:20 +0000 (16:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 8 Oct 2008 16:31:20 +0000 (16:31 +0000)
SVN-Revision: 12910

libs/file/Makefile

index c7b67e39800809bd220116d46bb059cd5f9b0777..bbd905a278ab6e283dd9423c4975e6e4fb9ea127 100644 (file)
@@ -58,6 +58,11 @@ MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
        all install \
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 define Build/InstallDev
        mkdir -p $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/magic.h $(1)/usr/include/