[packages] ldns: add the ldns library (#9374), thanks Cybjit
authorStephen Walker <stephendwalker@gmail.com>
Wed, 13 Jul 2011 05:33:58 +0000 (05:33 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Wed, 13 Jul 2011 05:33:58 +0000 (05:33 +0000)
SVN-Revision: 27602

libs/ldns/Makefile [new file with mode: 0644]

diff --git a/libs/ldns/Makefile b/libs/ldns/Makefile
new file mode 100644 (file)
index 0000000..6facbc4
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ldns
+PKG_VERSION:=1.6.10
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.nlnetlabs.nl/downloads/ldns
+PKG_MD5SUM:=fadf8e38fbd2d3434a2c46097d9932d5
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_LIBTOOL_PATHS:= ./libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libldns
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A library to simplify DNS programming
+  URL:=http://www.nlnetlabs.nl/projects/ldns/
+  DEPENDS:=+libopenssl
+endef
+
+CONFIGURE_ARGS += \
+       --disable-gost \
+       --with-ssl="$(STAGING_DIR)/usr"
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/ldns
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ldns/*.h $(1)/usr/include/ldns/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libldns.{so*,a,la} $(1)/usr/lib/
+endef
+
+define Package/libldns/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libldns.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libldns))