add index.asp (symlinked from index.html) to make the transition from other broadcom...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 25 Jul 2006 19:07:23 +0000 (19:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 25 Jul 2006 19:07:23 +0000 (19:07 +0000)
SVN-Revision: 4284

openwrt/package/webif/Makefile
openwrt/package/webif/files/etc/httpd.conf [new file with mode: 0644]
openwrt/package/webif/files/usr/lib/webif/webif.sh

index ae4419ab552030b17b149b143fe795ff1a9220a3..a3ae5712c8979fdee51bf5cac4d42270b105028e 100644 (file)
@@ -33,6 +33,7 @@ $(IPKG_WEBIF):
        install -d $(IDIR_WEBIF)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/webif-page $(IDIR_WEBIF)/usr/bin/webif-page
        install -m0755 $(PKG_BUILD_DIR)/bstrip $(IDIR_WEBIF)/usr/bin/bstrip
+       ln -sf /www/index.html $(IDIR_WEBIF)/www/index.asp
        find $(IDIR_WEBIF) -name CVS | xargs rm -rf
        find $(IDIR_WEBIF) -name .svn | xargs rm -rf
        $(IPKG_BUILD) $(IDIR_WEBIF) $(PACKAGE_DIR)
diff --git a/openwrt/package/webif/files/etc/httpd.conf b/openwrt/package/webif/files/etc/httpd.conf
new file mode 100644 (file)
index 0000000..0892ce8
--- /dev/null
@@ -0,0 +1 @@
+.asp:text/html
index a74fcb80158d48b8424a332d3fbb6553ba73bd2a..919dcdfd36faee2d8b08ac05c627f012a8589d83 100644 (file)
@@ -195,7 +195,8 @@ EOF
 apply_passwd() {
        case ${SERVER_SOFTWARE%% *} in
                busybox)
-                       echo '/cgi-bin/webif:root:$p$root' > /etc/httpd.conf
+                       echo ".asp:text/html" > /etc/httpd.conf
+                       echo '/cgi-bin/webif:root:$p$root' >> /etc/httpd.conf
                        echo '/cgi-bin/webif:admin:$p$root' >> /etc/httpd.conf
                        killall -HUP httpd
                        ;;