[packages] babeld: upgrade to babeld-1.3.0
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Tue, 13 Dec 2011 14:29:34 +0000 (14:29 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Tue, 13 Dec 2011 14:29:34 +0000 (14:29 +0000)
8 December 2011: babeld-1.3.0

  * Made the route table into a sorted array, and use binary sort for
    searching for routes.  This makes most route operations O(log n), at
    a slight cost in memory usage.
  * Changed the update sending strategy to use buffers large enough for
    a full update.  This makes the duplicate suppression mechanism
    effective in large networks, at a small cost in memory usage.
  * Rate-limit the reaction to wildcard requests.  This avoids an update
    storm at boot in large networks.
  * Fixed a bug that prevented usage of the "default" keyword in
    configuration files.

SVN-Revision: 29512

net/babel/Makefile

index 774ed8e4cf97e20835f11860ae952cfe47cb4988..88bc6bc70bb7ec7c51aefd623226fbfc21f1f63c 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.2.0
+PKG_VERSION:=1.3.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=2f5a9e3a0e23fecbbcdf0c85fca77a95
+PKG_MD5SUM:=05fc458d159b9b6fbf9c2f2f20eb8291
 
 include $(INCLUDE_DIR)/package.mk