port openldap (client libraries and utilities) to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Tue, 18 Jul 2006 16:19:27 +0000 (16:19 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 18 Jul 2006 16:19:27 +0000 (16:19 +0000)
SVN-Revision: 4147

libs/openldap/Makefile [new file with mode: 0644]
libs/openldap/patches/500-cross-compile.patch [new file with mode: 0644]
libs/openldap/patches/750-no-strip.patch [new file with mode: 0644]

diff --git a/libs/openldap/Makefile b/libs/openldap/Makefile
new file mode 100644 (file)
index 0000000..6a956c7
--- /dev/null
@@ -0,0 +1,171 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openldap
+PKG_VERSION:=2.2.29
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
+       ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/ \
+       ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
+       ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
+PKG_MD5SUM:=6c4c72a1336aa45b463e738034c078d6
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_CONFIGURE_OPTIONS = \
+       --enable-shared \
+       --enable-static \
+       --disable-debug \
+       --enable-dynamic \
+       --enable-syslog \
+       --disable-local \
+       --disable-slapd \
+       --disable-slurpd \
+       --with-cyrus-sasl \
+       --without-fetch \
+       --with-threads \
+       --with-tls \
+       --with-yielding_select="yes" \
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libopenldap
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libopenssl +libsasl2
+  TITLE:=LDAP client libraries
+  DESCRIPTION:=LDAP (Lightweight Directory Access Protocol) client libraries.\\\
+    OpenLDAP Software is an open source implementation of the \\\
+    Lightweight Directory Access Protocol (LDAP).\\\
+    \\\
+    This package contains the shared LDAP client libraries, needed by other \\\
+    programs.
+  URL:=http://www.openldap.org/
+endef
+
+define Package/libopenldap/conffiles
+/etc/openldap/ldap.conf
+endef
+
+define Package/openldap-utils
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=libopenldap
+  TITLE:=LDAP client utilities
+  DESCRIPTION:=LDAP (Lightweight Directory Access Protocol) client utilities.\\\
+    OpenLDAP Software is an open source implementation of the \\\
+    Lightweight Directory Access Protocol (LDAP).\\\
+    \\\
+    This package contains client programs required to access LDAP servers.
+  URL:=http://www.openldap.org/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               ./configure \
+                       --target=$(GNU_HOST_NAME) \
+                       --host=$(GNU_HOST_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       $(PKG_CONFIGURE_OPTIONS) \
+                       --without-cyrus-sasl \
+                       --without-threads \
+                       --without-tls \
+       );
+       $(MAKE) -C $(PKG_BUILD_DIR) depend 
+       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil
+       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber
+       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblunicode
+       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber clean
+       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil clean
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
+               ac_cv_func_memcmp_clean="yes" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       $(PKG_CONFIGURE_OPTIONS) \
+       );
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/libopenldap/install
+       install -m0755 -d $(1)/etc/openldap
+       $(CP) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
+       install -m0755 -d $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
+       install -m0755 -d $(1)/usr/share/openldap
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/openldap/* $(1)/usr/share/openldap/
+endef
+       
+define Package/openldap-utils/install
+       install -m0755 -d $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
+endef
+       
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/{lber,ldap}*.h \
+               $(STAGING_DIR)/usr/lib/lib{lber,ldap}*.{a,so*}
+endef
+
+$(eval $(call BuildPackage,libopenldap))
+$(eval $(call BuildPackage,openldap-utils))
diff --git a/libs/openldap/patches/500-cross-compile.patch b/libs/openldap/patches/500-cross-compile.patch
new file mode 100644 (file)
index 0000000..d0aafdc
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ruN openldap-2.2.26-orig/libraries/liblunicode/Makefile.in openldap-2.2.26-1/libraries/liblunicode/Makefile.in
+--- openldap-2.2.26-orig/libraries/liblunicode/Makefile.in     2005-01-20 18:01:03.000000000 +0100
++++ openldap-2.2.26-1/libraries/liblunicode/Makefile.in        2005-05-08 15:47:08.000000000 +0200
+@@ -29,7 +29,7 @@
+ LDAP_INCDIR= ../../include       
+ LDAP_LIBDIR= ../../libraries
+-ucgendat: $(XLIBS) ucgendat.o
++ucgendat: ucgendat.o
+       $(LTLINK) -o $@ ucgendat.o $(LIBS)
+       ./ucgendat $(srcdir)/UnicodeData.txt -x $(srcdir)/CompositionExclusions.txt
diff --git a/libs/openldap/patches/750-no-strip.patch b/libs/openldap/patches/750-no-strip.patch
new file mode 100644 (file)
index 0000000..d472fd8
--- /dev/null
@@ -0,0 +1,36 @@
+diff -ruN openldap-2.2.26-orig/clients/tools/Makefile.in openldap-2.2.26-1/clients/tools/Makefile.in
+--- openldap-2.2.26-orig/clients/tools/Makefile.in     2005-01-20 18:00:55.000000000 +0100
++++ openldap-2.2.26-1/clients/tools/Makefile.in        2005-05-08 15:47:08.000000000 +0200
+@@ -98,7 +98,7 @@
+       -$(MKDIR) $(DESTDIR)$(bindir)
+       @(                                                              \
+           for prg in $(PROGRAMS); do                                  \
+-              $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 $$prg$(EXEEXT)   \
++              $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT)      \
+                   $(DESTDIR)$(bindir);                                \
+           done                                                        \
+       )
+diff -ruN openldap-2.2.26-orig/servers/slapd/Makefile.in openldap-2.2.26-1/servers/slapd/Makefile.in
+--- openldap-2.2.26-orig/servers/slapd/Makefile.in     2005-01-20 18:01:05.000000000 +0100
++++ openldap-2.2.26-1/servers/slapd/Makefile.in        2005-05-08 15:47:08.000000000 +0200
+@@ -355,7 +355,7 @@
+ install-slapd: FORCE
+       -$(MKDIR) $(DESTDIR)$(libexecdir)
+       -$(MKDIR) $(DESTDIR)$(localstatedir)/run
+-      $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 \
++      $(LTINSTALL) $(INSTALLFLAGS) -m 755 \
+               slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
+       @for i in $(SUBDIRS); do \
+           if test -d $$i -a -f $$i/Makefile ; then \
+diff -ruN openldap-2.2.26-orig/servers/slurpd/Makefile.in openldap-2.2.26-1/servers/slurpd/Makefile.in
+--- openldap-2.2.26-orig/servers/slurpd/Makefile.in    2005-01-20 18:01:19.000000000 +0100
++++ openldap-2.2.26-1/servers/slurpd/Makefile.in       2005-05-08 15:47:08.000000000 +0200
+@@ -60,7 +60,7 @@
+       @-$(INSTALL) -m 700 -d $(DESTDIR)$(localstatedir)/openldap-slurp
+       @(                                                              \
+           for prg in $(PROGRAMS); do                                  \
+-              $(LTINSTALL) $(INSTALLFLAGS) -s -m 755 $$prg$(EXEEXT)   \
++              $(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT)      \
+                   $(DESTDIR)$(libexecdir);                            \
+           done                                                        \
+       )