Disable by default openpvn-webif since we are missing a file
authorFlorian Fainelli <florian@openwrt.org>
Sun, 21 May 2006 13:50:28 +0000 (13:50 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 21 May 2006 13:50:28 +0000 (13:50 +0000)
Add kmod-pcmcia-serial, thanks Kheru

SVN-Revision: 3812

openwrt/package/openvpn/Config.in
openwrt/target/linux/Config.in
openwrt/target/linux/linux-2.4/Makefile

index d1ec8566ed06e841d6e0777146ade63c8bdc8bcb..d6b8aa16c1c927d73f8ab837daa12894d0bb58f5 100644 (file)
@@ -18,7 +18,7 @@ config BR2_PACKAGE_OPENVPN_EASY_RSA
 
 config BR2_PACKAGE_OPENVPN_WEBIF
        tristate "openvpn-webif - web interface module to configure OpenVPN (client mode)"
-       default m
+       default n
        depends BR2_PACKAGE_OPENVPN
        select BR2_PACKAGE_WEBIF
        help
index 49f6521e00e7ff4264a4992352598809a2d8c9db..d65db55057553fec91a0e0c2167a13828a2e2ad5 100644 (file)
@@ -288,6 +288,10 @@ config BR2_PACKAGE_KMOD_PCMCIA
        tristate "Support for PCMCIA devices"
        default m
 
+config BR2_PACKAGE_KMOD_PCMCIA_SERIAL
+       tristate "Support for PCMCIA/Cardbus serial devices"
+       default m
+
 config BR2_PACKAGE_KMOD_IDE
        tristate "IDE support"
        default m
index 16204b3cc2025365ab82627ab6b64151de8259e8..a8deae670755fd4e0df5a61033c540cc337efbcc 100644 (file)
@@ -113,6 +113,9 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
 $(eval $(call KMOD_template,PCMCIA,pcmcia,\
        $(MODULES_DIR)/kernel/drivers/pcmcia/*.o \
 ,CONFIG_PCMCIA))
+$(eval $(call KMOD_template,PCMCIA_SERIAL,pcmcia-serial, \
+       $(MODULES_DIR)/kernel/drivers/char/pcmcia/serial_cs.o \
+,CONFIG_PCMCIA_SERIAL_CS))
 $(eval $(call KMOD_template,B44,b44,\
        $(MODULES_DIR)/kernel/drivers/net/b44.o \
 ,CONFIG_B44))