[packages] debootstrap: update to v1.0.42 (#11818)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Jul 2012 16:11:00 +0000 (16:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Jul 2012 16:11:00 +0000 (16:11 +0000)
SVN-Revision: 32650

admin/debootstrap/Makefile
admin/debootstrap/patches/100-busybox_fix.patch

index 6e6d39d797fe1f67dba1fb4825c2139b9420aa1d..63d98faa3df1914d07d2dae52bffec4c0e9fcf12 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=debootstrap
-PKG_VERSION:=1.0.40
+PKG_VERSION:=1.0.42
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-udeb_$(PKG_VERSION)_all.udeb
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debootstrap
-PKG_MD5SUM:=298ed4d39eda12b9db46f446465d6f7f
+PKG_MD5SUM:=749638b8afc0c3e2a06c9b31cfe40b55
 
-UNPACK_CMD=ar -p "$(DL_DIR)/$(PKG_SOURCE)" data.tar.gz | ( cd $(1) && tar -xzf - )
+UNPACK_CMD=ar -p "$(DL_DIR)/$(PKG_SOURCE)" data.tar.xz | xzcat | tar -C $(1) -xf -
 
 include $(INCLUDE_DIR)/package.mk
 
index 0b248c7e6f65f286a07124d89fc10b0d2e480350..74875a0b80501d6eb7a6101867db4dc9a50b2edf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/usr/share/debootstrap/functions
 +++ b/usr/share/debootstrap/functions
-@@ -832,8 +832,6 @@ choose_extractor () {
+@@ -857,8 +857,6 @@ choose_extractor () {
  
        if [ -n "$EXTRACTOR_OVERRIDE" ]; then
                extractor="$EXTRACTOR_OVERRIDE"