add wrt54g v4 support
authorFelix Fietkau <nbd@openwrt.org>
Mon, 22 Aug 2005 01:57:20 +0000 (01:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 22 Aug 2005 01:57:20 +0000 (01:57 +0000)
SVN-Revision: 1715

openwrt/target/linux/linux-2.4/patches/brcm/004-diag_led.patch

index 77fb289797de388f56f965772cc7f46cb44d343a..7ec20df5725bfffe7806d1c2123459b4fcca324c 100644 (file)
@@ -1,8 +1,20 @@
-diff -Nur linux-2.4.30/drivers/net/diag/Makefile linux-2.4.30.openwrt/drivers/net/diag/Makefile
---- linux-2.4.30/drivers/net/diag/Makefile     1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.30.openwrt/drivers/net/diag/Makefile     2005-06-28 11:35:26.000000000 +0200
+diff -urN linux-2.4.30.dev/drivers/net/Makefile linux-2.4.30.dev2/drivers/net/Makefile
+--- linux-2.4.30.dev/drivers/net/Makefile      2005-08-22 01:41:45.930653216 +0200
++++ linux-2.4.30.dev2/drivers/net/Makefile     2005-08-22 01:58:04.162939304 +0200
+@@ -41,6 +41,8 @@
+   obj-$(CONFIG_ISDN) += slhc.o
+ endif
++subdir-m += diag
++
+ subdir-$(CONFIG_HND) += hnd
+ subdir-$(CONFIG_ET) += et
+ subdir-$(CONFIG_WL) += wl
+diff -urN linux-2.4.30.dev/drivers/net/diag/Makefile linux-2.4.30.dev2/drivers/net/diag/Makefile
+--- linux-2.4.30.dev/drivers/net/diag/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ linux-2.4.30.dev2/drivers/net/diag/Makefile        2005-08-22 00:12:23.655170000 +0200
 @@ -0,0 +1,13 @@
-+#$Id$
++#$Id: 005-diag_led.patch,v 1.1.2.1 2005/08/22 01:56:06 nbd Exp $
 +
 +EXTRA_CFLAGS := -I$(TOPDIR)/arch/mips/bcm947xx/include -DBCMDRIVER
 +
@@ -15,10 +27,10 @@ diff -Nur linux-2.4.30/drivers/net/diag/Makefile linux-2.4.30.openwrt/drivers/ne
 +obj-m          := $(O_TARGET)
 +
 +include $(TOPDIR)/Rules.make
-diff -Nur linux-2.4.30/drivers/net/diag/diag_led.c linux-2.4.30.openwrt/drivers/net/diag/diag_led.c
---- linux-2.4.30/drivers/net/diag/diag_led.c   1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.30.openwrt/drivers/net/diag/diag_led.c   2005-06-28 11:35:26.000000000 +0200
-@@ -0,0 +1,244 @@
+diff -urN linux-2.4.30.dev/drivers/net/diag/diag_led.c linux-2.4.30.dev2/drivers/net/diag/diag_led.c
+--- linux-2.4.30.dev/drivers/net/diag/diag_led.c       1970-01-01 01:00:00.000000000 +0100
++++ linux-2.4.30.dev2/drivers/net/diag/diag_led.c      2005-08-22 03:37:58.112053448 +0200
+@@ -0,0 +1,245 @@
 +/*
 + * diag_led.c - replacement diag module
 + *
@@ -39,7 +51,7 @@ diff -Nur linux-2.4.30/drivers/net/diag/diag_led.c linux-2.4.30.openwrt/drivers/
 + * along with this program; if not, write to the Free Software
 + * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 + *
-+ * $Id: diag_led.c,v 1.5 2005/04/18 09:05:24 mbm Exp $
++ * $Id: 005-diag_led.patch,v 1.1.2.1 2005/08/22 01:56:06 nbd Exp $
 + */
 +
 +/*
@@ -191,7 +203,8 @@ diff -Nur linux-2.4.30/drivers/net/diag/diag_led.c linux-2.4.30.openwrt/drivers/
 +      set_diag=ignore;
 +      set_dmz=ignore;
 +      
-+      if ((board_type & 0xf00) == 0x400) {
++      buf=nvram_get("boardrev");
++      if (((board_type & 0xf00) == 0x400) && strcmp(buf,"0x10")) {
 +              buf=nvram_get("boardtype")?:"";
 +              if (!strcmp(buf,"bcm94710dev")) {
 +                      buf=nvram_get("boardnum")?:"";