[x86] add rootwait option to the kernel command line (#6209)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Dec 2009 09:12:34 +0000 (09:12 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Dec 2009 09:12:34 +0000 (09:12 +0000)
SVN-Revision: 18672

target/linux/x86/image/Makefile

index b412873c38404b63ca2c8344ad5e7f49e3168156..51490fa791a2457a90fa31f5ebed2d5747968b1c 100644 (file)
@@ -23,19 +23,19 @@ endif
 ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
 ifneq ($(HOST_OS),Darwin)
   define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs
+    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
   endef
 
   define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
   endef
 
   define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2
+    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
   endef
 
   define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2
+    root=$(ROOTPART) rootfstype=ext2 rootwait
   endef
   
   define Image/Build/grub