Add zip from #1313
authorFlorian Fainelli <florian@openwrt.org>
Mon, 14 May 2007 21:51:07 +0000 (21:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 14 May 2007 21:51:07 +0000 (21:51 +0000)
SVN-Revision: 7241

utils/zip/Makefile [new file with mode: 0644]

diff --git a/utils/zip/Makefile b/utils/zip/Makefile
new file mode 100644 (file)
index 0000000..c2fc9b0
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $ 
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=zip
+PKG_VERSION:=2.32
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)232.zip
+PKG_SOURCE_URL:=@SF/infozip
+PKG_MD5SUM:=da947ed356e5fdb30ff4bc3dc7698f33
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/zip
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=
+  TITLE:=Archiver for .zip files
+  DESCRIPTION:=\
+       This is InfoZIP's zip program. It produces files that are fully \\\
+       compatible with the popular PKZIP program; however, the command line \\\
+       options are not identical. In other words, the end result is the same, \\\
+       but the methods differ.
+  URL:=http://infozip.sourceforge.net/Zip.html
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
+               $(TARGET_CONFIGURE_OPTS) \
+               prefix="$(PKG_INSTALL_DIR)/usr" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CF="$(TARGET_CFLAGS) -O -I$(STAGING_DIR)/usr/include -I. -DUNIX" \
+               LD="$(TARGET_CC) -L$(STAGING_DIR)/usr/lib" \
+               install
+endef
+
+define Package/zip/install     
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,zip))