add base-files change from whiterussian
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 19:54:33 +0000 (19:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 19:54:33 +0000 (19:54 +0000)
SVN-Revision: 2257

openwrt/package/base-files/Makefile
openwrt/package/base-files/default/sbin/mount_root

index c1dd8c69fc289ed85778678fd7a9784ac5879b78..869e3c67d1477b90cd059060e7142542fdf7d762 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
 
 REV:=${shell svn info | grep Revision | cut -d ' ' -f 2}
index bc8d69c79baf1c352368bdc475e149cc7b259bd2..c8edaaa2fa1e913812b9fcc30a07c85473257dbd 100755 (executable)
@@ -1,10 +1,15 @@
 #!/bin/sh
 . /etc/nvram.sh
+is_clean() {
+       OFFSET="$((0x$(dd if=/dev/mtdblock/1 bs=1 skip=$((0x14)) count=2 2>&- | hexdump | grep 0000000 | cut -d ' ' -f 2) - 1))"
+       dd if=/dev/mtdblock/1 bs=1 skip=$OFFSET count=1 2>&- | hexdump -v | grep ' 0000' > /dev/null && return 255 || return 0
+}
+
 if [ "$1" != "failsafe" ]; then 
        mount | grep jffs2 >&-
        if [ $? = 0 ] ; then
                if [ $(cat /proc/mtd | wc -l) = 6 ]; then
-                       [ -f /proc/sys/diag ] && echo 5 > /proc/sys/diag
+                       echo 5 > /proc/sys/diag
                        mtd unlock linux
                        mtd erase OpenWrt
                        jffs2root --move
@@ -13,7 +18,11 @@ if [ "$1" != "failsafe" ]; then
                        mount -o remount,rw /dev/root /
                fi
        else
-               if [ \! -x /usr/sbin/nvram -o -z "$(nvram get no_root_swap)" ]; then
+               if [ -z "$(nvram get no_root_swap)" ]; then
+                       is_clean || {
+                               mtd erase OpenWrt
+                               jffs2root --clean
+                       }
                        mtd unlock OpenWrt
                        mount -t jffs2 /dev/mtdblock/4 /jffs
                        pivot_root /jffs /jffs/rom