[PATCH 1/2] kernel: add kmod-crypto-{wq,rng,iv}
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 3 May 2011 21:19:56 +0000 (21:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 3 May 2011 21:19:56 +0000 (21:19 +0000)
This patch adds kmod-crypto-wq, kmod-crypto-rng, and kmod-crypto-iv
packages. These packages provide some missing kernel crypto modules
which are required for IPSEC. The strongswan4, ipsec-tools, and possibly
other IPSEC packages do not work properly without these modules.

NOTE: The KCONFIG associated with each of these modules gets selected
whenever CRYPTO_MANAGER (kmod-crypto-manager) is selected so these
modules are already being built.

Signed-off-by: Lars Hjersted <lars@hjersted.com>
SVN-Revision: 26812

package/kernel/modules/crypto.mk

index b895224b2ccb49819d02136f9d0a21e6956012b3..5aa954900d9e92d81dd86e1e0946b816a3b33af6 100644 (file)
@@ -76,6 +76,38 @@ define KernelPackage/crypto-manager
 endef
 $(eval $(call KernelPackage,crypto-manager))
 
+define KernelPackage/crypto-wq
+  TITLE:=CryptoAPI work queue handling
+  KCONFIG:=CONFIG_CRYPTO_WORKQUEUE
+  FILES:=$(LINUX_DIR)/crypto/crypto_wq.ko
+  AUTOLOAD:=$(call AutoLoad,09,crypto_wq)
+  $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-wq))
+
+define KernelPackage/crypto-rng
+  TITLE:=CryptoAPI random number generation
+  KCONFIG:=CONFIG_CRYPTO_RNG2
+  FILES:= \
+       $(LINUX_DIR)/crypto/rng.ko \
+       $(LINUX_DIR)/crypto/krng.ko
+  AUTOLOAD:=$(call AutoLoad,09,rng krng)
+  $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-rng))
+
+define KernelPackage/crypto-iv
+  TITLE:=CryptoAPI initialization vectors
+  DEPENDS:=+kmod-crypto-rng +kmod-crypto-wq
+  KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2
+  FILES:= \
+       $(LINUX_DIR)/crypto/eseqiv.ko \
+       $(LINUX_DIR)/crypto/chainiv.ko
+  AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
+  $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-iv))
+
 define KernelPackage/crypto-hw-padlock
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
   DEPENDS:=+kmod-crypto-aes