[toolchain] invoke patch-specs.sh in the gcc/final install stage.
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jan 2012 03:15:22 +0000 (03:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jan 2012 03:15:22 +0000 (03:15 +0000)
Patch up OpenWrts own cross toolchains to always search headers
and libraries in $STAGING_DIR, this should solve most issues with
missing headers, indirect linking and not found libraries.
At a later stage, all -I and -L flags will be purged from
TARGET_LDFLAGS and TARGET_CPPFLAGS.

SVN-Revision: 29768

toolchain/gcc/final/Makefile

index dc884ab9c101c996fe6a5b7a3388de73afc17e9d..dcab9094e2cab7dc9684fd67b8871991daad8aec 100644 (file)
@@ -70,6 +70,7 @@ define Host/Install
                done; \
        );
        $(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
+       $(SCRIPT_DIR)/patch-specs.sh "$(TOOLCHAIN_DIR)"
 endef
 
 $(eval $(call HostBuild))