[packages] multiwan: Fixed last WAN probability to be 1.0.
authorCraig M. Coffee <cmcoffee@gmail.com>
Mon, 10 May 2010 16:54:53 +0000 (16:54 +0000)
committerCraig M. Coffee <cmcoffee@gmail.com>
Mon, 10 May 2010 16:54:53 +0000 (16:54 +0000)
SVN-Revision: 21416

net/multiwan/Makefile
net/multiwan/files/usr/bin/multiwan

index d7c98dfbe3185b1ebb48255d91bb6bad38ebc20b..563b8cc993d9a4b80c5ff338807e8b7903cec657 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
 PKG_VERSION:=1.0.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index 7e5a735b781d3c721793bf94fed4981254c051d0..f94166a34b244a0e9c14338666bf58fb9adfb636 100755 (executable)
@@ -692,7 +692,7 @@ last_probability=$rand_probability
 
         if [ $rand_probability -lt 10 ]; then
                 rand_probability="0.0${rand_probability}"
-        elif [ $rand_probability -lt 100 ]; then
+        elif [ $rand_probability -lt 100 -a $i != $wancount ]; then
                 rand_probability="0.${rand_probability}"
         else
                 rand_probability="1.0"