uboot-envtools: add support for mxs target
authorZoltan Herpai <wigyori@uid0.hu>
Tue, 12 Nov 2013 10:07:03 +0000 (10:07 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Tue, 12 Nov 2013 10:07:03 +0000 (10:07 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 38776

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/mxs [new file with mode: 0644]

index a0512284d5f7048ab6d17bb62cb594d1738af9b9..0a304ac0bbbfb0ff0f21e4ef9b647be018150c32 100644 (file)
@@ -76,6 +76,10 @@ ifneq ($(CONFIG_TARGET_lantiq),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
 endif
+ifneq ($(CONFIG_TARGET_mxs),)
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_BIN) ./files/mxs $(1)/etc/uci-defaults/30_uboot-envtools
+endif
 ifneq ($(CONFIG_TARGET_ramips),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/ramips $(1)/etc/uci-defaults/30_uboot-envtools
diff --git a/package/boot/uboot-envtools/files/mxs b/package/boot/uboot-envtools/files/mxs
new file mode 100644 (file)
index 0000000..ab8b4ef
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/mxs.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+board=$(mxs_board_name)
+
+case "$board" in
+duckbill)
+       ubootenv_add_uci_config "/dev/mmcblk0" "0x20000" "0x20000"
+       ubootenv_add_uci_config "/dev/mmcblk0" "0x40000" "0x20000"
+       ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0