[package] update nodogsplash to 0.9-beta9.9.5, fix interface names in config files...
authorFlorian Fainelli <florian@openwrt.org>
Sun, 20 Sep 2009 12:52:15 +0000 (12:52 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 20 Sep 2009 12:52:15 +0000 (12:52 +0000)
SVN-Revision: 17640

net/nodogsplash/Makefile

index d21a299b955d4d4963d00fbcc6fafdfb6b141b7f..516d1ce2f7c6bd0877d8c2d1355d1e1f057dda20 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_VERSION:=0.9_beta9.9
-PKG_RELEASE:=2
+PKG_VERSION:=0.9_beta9.9.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://kokoro.ucsd.edu/nodogsplash/ \
        http://kokoro.ucsd.edu/nodogsplash/old/
-PKG_MD5SUM:=96e597977717610186ed09ebd7fa54cf
+#PKG_MD5SUM:=96e597977717610186ed09ebd7fa54cf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,7 +22,7 @@ define Package/nodogsplash
   SUBMENU:=Captive Portals
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +iptables-mod-ipopt
   TITLE:=Open public network gateway daemon
   URL:=http://kokoro.ucsd.edu/nodogsplash/
 endef
@@ -40,7 +40,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/usr/{share{,/doc/$(PKG_NAME)-$(PKG_VERSION)},lib,include{,/nodogsplash},bin,sbin}/
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -48,16 +48,20 @@ define Build/Compile
                install
 endef
 
-define Package/nodogsplash/install     
+define Package/nodogsplash/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME)/
+       $(SED) 's,br0,br-lan,' $(1)/etc/$(PKG_NAME)/$(PKG_NAME).conf
        $(CP) $(PKG_BUILD_DIR)/htdocs $(1)/etc/$(PKG_NAME)/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/
+       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+       $(SED) 's,\(do_module_tests "imq"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
+       $(SED) 's,\(do_module_tests "ipt_IMQ"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
+       $(SED) 's,\(do_module_tests "sch_htb"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
 endef
 
 $(eval $(call BuildPackage,nodogsplash))