[kernel] update to 2.6.28.4
authorGabor Juhos <juhosg@openwrt.org>
Sun, 8 Feb 2009 13:01:28 +0000 (13:01 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 8 Feb 2009 13:01:28 +0000 (13:01 +0000)
SVN-Revision: 14441

16 files changed:
include/kernel-version.mk
target/linux/avr32/Makefile
target/linux/generic-2.6/patches-2.6.28/180-netfilter_depends.patch
target/linux/generic-2.6/patches-2.6.28/960-fix-serial_h-includes.patch
target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
target/linux/ixp4xx/Makefile
target/linux/ixp4xx/patches-2.6.28/500-usr8200_support.patch
target/linux/orion/Makefile
target/linux/ppc44x/Makefile
target/linux/ppc44x/patches/004-canyonlands_dts_sync.patch
target/linux/ppc44x/patches/005-canyonlands_remove_nonexisting_uarts.patch
target/linux/ppc44x/patches/100-openwrt_dts_cmdline.patch
target/linux/s3c24xx/Makefile
target/linux/s3c24xx/patches-2.6.28/003-disable-xt-chaos.patch [deleted file]
target/linux/sibyte/Makefile
target/linux/x86/Makefile

index e481a32538e31cc91f75e2840e5cb27dcb051def..fb97957af0f5cb2a9fbcf618b0d9ab44a840d0a0 100644 (file)
@@ -31,8 +31,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.27.15)
   LINUX_KERNEL_MD5SUM:=0756284efb091dccd012eec61def2004
 endif
-ifeq ($(LINUX_VERSION),2.6.28.2)
-  LINUX_KERNEL_MD5SUM:=8fce853ebfe658f0833d34bb1dc14d86
+ifeq ($(LINUX_VERSION),2.6.28.4)
+  LINUX_KERNEL_MD5SUM:=8228bb7804d6d0099eadfabf701c295b
 endif
 
 # disable the md5sum check for unknown kernel versions
index da6cd7aa22c8eb7d9e5685da1bfdebe1656a1d94..69e2199bdb250ccc9d2eab6963796ccf1de2836d 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 44f9fcb183ef8f554afe4ae8924881d6e9c6cfda..9144417129a1d87f8603110d98a97ec0f3187a3a 100644 (file)
@@ -8,7 +8,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -488,7 +487,6 @@ config NETFILTER_XT_TARGET_TARPIT
+@@ -455,7 +454,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index 38ddc4e7e4f5af281d20c8329f76ceaa0b370290..093ff590b0b5d77f34f83cdad2788ea1b1f76f62 100644 (file)
@@ -5,8 +5,6 @@ Date:   Tue Feb 3 00:16:19 2009 +0100
     struct serial_rs485 contains __32 fields and is exported to userspace so it
     needs linux/types.h in userspace aswell.
 
-diff --git a/include/linux/serial.h b/include/linux/serial.h
-index 1ea8d92..fa72b39 100644
 --- a/include/linux/serial.h
 +++ b/include/linux/serial.h
 @@ -10,8 +10,8 @@
index e0c7387cf06d80aeaed6619f5b6e322c7a38571e..076102e26f3338b28bcf7499d078974bb0e03efc 100644 (file)
@@ -95,7 +95,7 @@
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -981,6 +981,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -992,6 +992,7 @@ void unmap_kernel_range(unsigned long ad
        vunmap_page_range(addr, end);
        flush_tlb_kernel_range(addr, end);
  }
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1086,6 +1087,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1097,6 +1098,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
index 6a7ba81c4636e67d40b40b890920a1c48a7495ad..d8793068cd0bc6e6680fd67ad73f4656fcd62086 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 802854cc4c62f465afae70fca3944635756651cb..d0175044db480475e37c8d5e8a80be4c1eb7ec78 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -98,6 +98,14 @@ config MACH_SIDEWINDER
+@@ -97,6 +97,14 @@ config MACH_SIDEWINDER
          Engineering Sidewinder board. For more information on this
          platform, see http://www.adiengineering.com
  
index cc57848a1dd61c89e0e1b268a1f78392c0c2d98c..313cac3853b749f63d454b6f88da30be4e5e3939 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 4f023a38d3d12e5d1c998d4dfe63783473a7581c..00c0d723a695a150eb22ddabc88dd2b15f5b3c65 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 83e6c74e1a25be5dbf1ae64f61d51eada8496943..c89664299c251c5b3012fbcc1187de1f613648f5 100644 (file)
@@ -69,7 +69,7 @@
                POB0: opb {
                        compatible = "ibm,opb-460ex", "ibm,opb";
                        #address-cells = <1>;
-@@ -222,6 +282,12 @@
+@@ -222,6 +270,12 @@
                                reg = <0xef600700 0x00000014>;
                                interrupt-parent = <&UIC0>;
                                interrupts = <0x2 0x4>;
@@ -82,7 +82,7 @@
                        };
  
                        IIC1: i2c@ef600800 {
-@@ -331,6 +397,7 @@
+@@ -331,6 +385,7 @@
                         * later cannot be changed
                         */
                        ranges = <0x02000000 0x00000000 0x80000000 0x0000000d 0x80000000 0x00000000 0x80000000
@@ -90,7 +90,7 @@
                                  0x01000000 0x00000000 0x00000000 0x0000000c 0x08000000 0x00000000 0x00010000>;
  
                        /* Inbound 2GB range starting at 0 */
-@@ -361,6 +428,7 @@
+@@ -361,6 +416,7 @@
                         * later cannot be changed
                         */
                        ranges = <0x02000000 0x00000000 0x80000000 0x0000000e 0x00000000 0x00000000 0x80000000
@@ -98,7 +98,7 @@
                                  0x01000000 0x00000000 0x00000000 0x0000000f 0x80000000 0x00000000 0x00010000>;
  
                        /* Inbound 2GB range starting at 0 */
-@@ -402,6 +470,7 @@
+@@ -402,6 +458,7 @@
                         * later cannot be changed
                         */
                        ranges = <0x02000000 0x00000000 0x80000000 0x0000000e 0x80000000 0x00000000 0x80000000
index e05278cf2f2d7b2cca28b22ade48e1c07b29123b..d0e08b7a9c788d2d48a2709d55af69e5472dd8e9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/boot/dts/canyonlands.dts
 +++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -195,28 +195,6 @@
+@@ -243,28 +243,6 @@
                                interrupts = <0x1 0x4>;
                        };
  
index 3ab51d8db794896c2792daf24bae808cd120e7b8..3c1a7570a6440cd168a9d325b629c37b066b5765 100644 (file)
@@ -1,5 +1,5 @@
---- a/arch/powerpc/boot/dts/taishan.dts        2009-01-18 19:45:37.000000000 +0100
-+++ b/arch/powerpc/boot/dts/taishan.dts        2009-01-29 18:55:40.000000000 +0100
+--- a/arch/powerpc/boot/dts/taishan.dts
++++ b/arch/powerpc/boot/dts/taishan.dts
 @@ -423,5 +423,6 @@
  
        chosen {
index d6fc80a967c1bcd1f89605dce2df66b26f7ad660..4a1ed12c52c6e262f3d2c039837095967f69bf83 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=s3c24xx
 BOARDNAME:=s3c24xx
 FEATURES:=jffs2
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 
 DEVICE_TYPE=phone
 
diff --git a/target/linux/s3c24xx/patches-2.6.28/003-disable-xt-chaos.patch b/target/linux/s3c24xx/patches-2.6.28/003-disable-xt-chaos.patch
deleted file mode 100644 (file)
index b8c2e04..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Does not compile. --mb
-
----
---- a/net/netfilter/Kconfig
-+++ b/net/netfilter/Kconfig
-@@ -314,7 +314,7 @@ if NETFILTER_XTABLES
- config NETFILTER_XT_TARGET_CHAOS
-       tristate '"CHAOS" target support'
--      depends on NETFILTER_XTABLES
-+      depends on NETFILTER_XTABLES && BROKEN
-       help
-         This option adds a `CHAOS' target.
index c2dd4ec81538acde33b91e3af16eb1a089ba2126..7a8f38d6020242cf8944dc1d1a2ffdabf08db686 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 4367466e2e568af57fe46afeb2fb6f45de96c2d4..0dd1700f8291ae1177528d012e128eead7bf8652 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.28.2
+LINUX_VERSION:=2.6.28.4
 LINUX_KARCH:=x86
 
 include $(INCLUDE_DIR)/target.mk