[package] update hplip to 3.9.12 (#6597)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 19 Mar 2010 18:07:52 +0000 (18:07 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 19 Mar 2010 18:07:52 +0000 (18:07 +0000)
SVN-Revision: 20307

utils/hplip/Makefile
utils/hplip/files/20-hplip [new file with mode: 0644]

index 46ce2db6911ec95ef54bcd703671b3a27f465a99..15e6aa775c6773a6abf50872d4da305a98aa5d9c 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hplip
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hplip
-PKG_VERSION:=2.8.9
-PKG_RELEASE:=3
+PKG_VERSION:=3.9.12
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hplip
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hplip
-PKG_MD5SUM:=2e20dba86abb99a3ca59d05e814ce9a1
+PKG_MD5SUM:=2b0906b4a57b437988829557ca62adfd
 
 PKG_BUILD_DEPENDS := python
 PKG_FIXUP:=libtool
 
 PKG_BUILD_DEPENDS := python
 PKG_FIXUP:=libtool
@@ -45,7 +45,7 @@ define Build/Configure
        $(call Build/Configure/Default,\
                $(CONFIGURE_ARGS),\
                ac_cv_lib_cups_cupsDoFileRequest=yes \
        $(call Build/Configure/Default,\
                $(CONFIGURE_ARGS),\
                ac_cv_lib_cups_cupsDoFileRequest=yes \
-               LIBS="-ljpeg -lusb" \
+               LIBS="-lz -ljpeg -lusb -lcups -lpng -ltiff" \
        )
 endef
 
        )
 endef
 
@@ -53,7 +53,7 @@ define Package/hplip/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/.libs/libhpip.so* $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/.libs/libhpmud.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/.libs/libhpip.so* $(1)/usr/lib/
        $(CP) $(PKG_BUILD_DIR)/.libs/libhpmud.so* $(1)/usr/lib/
-       
+
        $(INSTALL_DIR) $(1)/usr/lib/cups/backend
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/hp $(1)/usr/lib/cups/backend
 
        $(INSTALL_DIR) $(1)/usr/lib/cups/backend
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/hp $(1)/usr/lib/cups/backend
 
@@ -65,6 +65,9 @@ define Package/hplip/install
 
        $(INSTALL_DIR) $(1)/usr/share/hplip/data/models/
        $(CP) $(PKG_BUILD_DIR)/data/models/models.dat $(1)/usr/share/hplip/data/models/
 
        $(INSTALL_DIR) $(1)/usr/share/hplip/data/models/
        $(CP) $(PKG_BUILD_DIR)/data/models/models.dat $(1)/usr/share/hplip/data/models/
+
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb/
+       $(INSTALL_BIN) ./files/20-hplip $(1)/etc/hotplug.d/usb/
 endef
 
 $(eval $(call BuildPackage,hplip))
 endef
 
 $(eval $(call BuildPackage,hplip))
diff --git a/utils/hplip/files/20-hplip b/utils/hplip/files/20-hplip
new file mode 100644 (file)
index 0000000..6066cc5
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# Copyright (C) 2009 OpenWrt.org
+
+
+case "$ACTION" in
+        add)
+                # You have to figure out your PRODUCT id. Uncomment the line below,
+                # attach and detach your HP USB printer to find your id in /tmp/hplip.test.
+                # It will look like "Found 3f0/1717/100 on /proc/bus/usb/002/009"
+                # Replace 3f0/1717/100 below with your id.
+                #
+                # echo "Found $PRODUCT on $DEVICE" > /tmp/hplip.test
+
+                [ "$PRODUCT" = "3f0/1717/100" ] && chown nobody $DEVICE && chmod 666 $DEVICE
+                ;;
+        remove)
+                # device is gone
+                ;;
+esac