fftw3 is broken on avr32
authorFelix Fietkau <nbd@openwrt.org>
Wed, 8 Oct 2008 16:31:22 +0000 (16:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 8 Oct 2008 16:31:22 +0000 (16:31 +0000)
SVN-Revision: 12911

libs/fftw3/Makefile

index 658bd0d07e54b78544af097e3a37744d154d5a75..ff58a30f9b4ae016085ca5f7a14a9c7fba9de730 100644 (file)
@@ -23,6 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/fftw3
   SECTION:=Libraries
   CATEGORY:=Libraries
+  DEPENDS:=@!avr32
   TITLE:=Fast Fourier transform library
   URL:=http://www.fftw.org/
 endef
@@ -35,6 +36,8 @@ define Package/fftw3/description
        http://www.fftw.org/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --prefix=/usr \
        --without-libiconv-prefix \