introduce new uci option "autostart" and modify xserver init scripts and window manag...
authorMirko Vogt <mirko@openwrt.org>
Wed, 21 Jan 2009 21:02:54 +0000 (21:02 +0000)
committerMirko Vogt <mirko@openwrt.org>
Wed, 21 Jan 2009 21:02:54 +0000 (21:02 +0000)
SVN-Revision: 14140

desktop/wm/karmen/Makefile
desktop/wm/karmen/files/uci-defaults/x11 [new file with mode: 0644]
desktop/wm/openbox/Makefile
desktop/wm/openbox/files/uci-defaults/x11 [new file with mode: 0644]
efl/enlightenment/Makefile
efl/enlightenment/files/uci-defaults/x11 [new file with mode: 0644]
xfce/wm/xfwm4/Makefile
xfce/wm/xfwm4/files/uci-defaults/x11 [new file with mode: 0644]

index 69683f0d968d7fc5b3dd9d2d62b12d781b9c7d82..1e206f446112ec4aaf475b2cb3b2e795d410feff 100644 (file)
@@ -45,6 +45,17 @@ define Package/karmen/install
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DATA) \
+               ./files/uci-defaults/x11 \
+               $(1)/etc/uci-defaults/
+endef
+
+define Package/karmen/postinst
+       #!/bin/sh
+       [ -n "$${IPKG_INSTROOT}" ] && exit
+       . /etc/functions.sh
+       uci_apply_defaults
 endef
 
 $(eval $(call BuildPackage,karmen))
diff --git a/desktop/wm/karmen/files/uci-defaults/x11 b/desktop/wm/karmen/files/uci-defaults/x11
new file mode 100644 (file)
index 0000000..aad2d58
--- /dev/null
@@ -0,0 +1 @@
+uci set x11.@desktop[0].autostart=karmen
index 490f88468c2c02bc7ef487215a9131b93f4cb0b9..5b8f3fbb8b3042f8ae2d65386b52ae5c83f5da91 100644 (file)
@@ -106,6 +106,18 @@ define Build/InstallDev
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
                $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DATA) \
+               ./files/uci-defaults/* \
+               $(1)/etc/uci-defaults/
+endef
+
+define Package/openbox/postinst
+       #!/bin/sh
+       [ -n "$${IPKG_INSTROOT}" ] && exit
+       . /etc/functions.sh
+       uci_apply_defaults
 endef
 
 $(eval $(call BuildPackage,openbox))
diff --git a/desktop/wm/openbox/files/uci-defaults/x11 b/desktop/wm/openbox/files/uci-defaults/x11
new file mode 100644 (file)
index 0000000..2062fb5
--- /dev/null
@@ -0,0 +1 @@
+uci set x11.@desktop[0].autostart=openbox
index 78dac2007a1ea45cbcdc814896e91268a9d9aca8..aaa96f34e2babe96d5dcc785a1ff4dbdff15a0f3 100644 (file)
@@ -62,7 +62,7 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include $(1)/usr/lib $(1)/usr/bin $(1)/usr/share
+       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/bin $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
@@ -70,22 +70,27 @@ define Build/InstallDev
 endef
 
 define Package/enlightenment/install
-       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/bin $(1)/usr/share
+       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/bin $(1)/usr/share $(1)/etc/uci-defaults
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/* $(1)/usr/share/
-       echo "#!/bin/sh" > $(1)/usr/bin/WM
-       echo -n "/usr/bin/enlightenment_start -profile " >> $(1)/usr/bin/WM
-       $(if $(CONFIG_E17_ILLUME),echo "illume" >> $(1)/usr/bin/WM)
-       $(if $(CONFIG_E17_MINIMALIST),echo "minimalist" >> $(1)/usr/bin/WM)
-       $(if $(CONFIG_E17_NETBOOK),echo "netbook" >> $(1)/usr/bin/WM)
-       $(if $(CONFIG_E17_SCALEABLE),echo "scaleable" >> $(1)/usr/bin/WM)
-       $(if $(CONFIG_E17_STANDARD),echo "standard" >> $(1)/usr/bin/WM)
-       chmod +x $(1)/usr/bin/WM
+       $(INSTALL_DATA) ./files/uci-defaults/x11 $(1)/etc/uci-defaults/
+       $(if $(CONFIG_E17_ILLUME),echo "illume" >> $(1)/etc/uci-defaults/x11)
+       $(if $(CONFIG_E17_MINIMALIST),echo "minimalist" >> $(1)/etc/uci-defaults/x11)
+       $(if $(CONFIG_E17_NETBOOK),echo "netbook" >> $(1)/etc/uci-defaults/x11)
+       $(if $(CONFIG_E17_SCALEABLE),echo "scaleable" >> $(1)/etc/uci-defaults/x11)
+       $(if $(CONFIG_E17_STANDARD),echo "standard" >> $(1)/etc/uci-defaults/x11)
        find $(1)/ -name *.la | xargs rm -f
        find $(1)/ -name *.a | xargs rm -f
 endef
 
+define Package/enlightenment/postinst
+       #!/bin/sh
+       [ -n "$${IPKG_INSTROOT}" ] && exit
+       . /etc/functions.sh
+       uci_apply_defaults
+endef
+
 $(eval $(call BuildPackage,enlightenment))
 $(eval $(call RequireCommand,edje_cc, \
        Command <edje_cc> not found - please install edje with edje-cc enabled \
diff --git a/efl/enlightenment/files/uci-defaults/x11 b/efl/enlightenment/files/uci-defaults/x11
new file mode 100644 (file)
index 0000000..0c8852f
--- /dev/null
@@ -0,0 +1 @@
+uci set x11.@desktop[0].autostart=enlightenment_start -profile 
\ No newline at end of file
index e44823e40863706d601766be54e30974924f1774..c794e35d813e50ff5240b45d3d256c5965a0e5fe 100644 (file)
@@ -65,6 +65,18 @@ define Package/xfwm4/install
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/xfwm4/* \
                $(1)/usr/share/xfwm4/
+
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DATA) \
+               ./files/uci-defaults/x11 \
+               $(1)/etc/uci-defaults/
+endef
+
+define Package/xfwm4/postinst
+       #!/bin/sh
+       [ -n "$${IPKG_INSTROOT}" ] && exit
+       . /etc/functions.sh
+       uci_apply_defaults
 endef
 
 $(eval $(call BuildPackage,xfwm4))
diff --git a/xfce/wm/xfwm4/files/uci-defaults/x11 b/xfce/wm/xfwm4/files/uci-defaults/x11
new file mode 100644 (file)
index 0000000..0629b2e
--- /dev/null
@@ -0,0 +1 @@
+uci set x11.@desktop[0].autostart=xfce4