Add libsamplerate from #1308
authorFlorian Fainelli <florian@openwrt.org>
Tue, 15 May 2007 08:54:07 +0000 (08:54 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 15 May 2007 08:54:07 +0000 (08:54 +0000)
SVN-Revision: 7251

libs/libsamplerate/Makefile [new file with mode: 0644]

diff --git a/libs/libsamplerate/Makefile b/libs/libsamplerate/Makefile
new file mode 100644 (file)
index 0000000..4648e56
--- /dev/null
@@ -0,0 +1,68 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $ Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsamplerate
+PKG_VERSION:=0.1.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.mega-nerd.com/SRC/
+PKG_MD5SUM:=6861c2c6b8e5273c9b80cf736b9fd0e
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libsamplerate
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libsndfile
+  TITLE:=Sample Rate Converter
+  DESCRIPTION:=\
+       Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio
+  URL:=http://www.mega-nerd.com/SRC/index.html
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-fftw \
+       )
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default,\
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install \
+       )
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.* $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/ao/ \
+               $(STAGING_DIR)/usr/lib/libao.{a,so*,la}
+endef
+
+define Package/libsamplerate/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/* $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsamplerate.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libsamplerate))