uClibc++: really really fix ccache issue
authorNicolas Thill <nico@openwrt.org>
Tue, 4 Sep 2007 07:51:47 +0000 (07:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 4 Sep 2007 07:51:47 +0000 (07:51 +0000)
SVN-Revision: 8605

libs/uclibc++/Makefile
libs/uclibc++/patches/004-ccache_fixes.patch [new file with mode: 0644]

index 0bef00829abfc11b5e249e750850e453b9ec9aa0..17716ba7e693154fdea97eb762e019d923cff184 100644 (file)
@@ -55,8 +55,6 @@ define Build/Configure
        else \
                cp ./files/config.default $(PKG_BUILD_DIR)/.config; \
        fi
-       # fix ccache issue
-       $(SED) 's,$$$$CC,$(TARGET_CROSS)gcc,g' $(PKG_BUILD_DIR)/scripts/find_lib*.sh
 endef
 
 define Build/Compile
diff --git a/libs/uclibc++/patches/004-ccache_fixes.patch b/libs/uclibc++/patches/004-ccache_fixes.patch
new file mode 100644 (file)
index 0000000..10ceb79
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN uClibc++-0.2.2-old/src/abi/libgcc_eh/Makefile uClibc++-0.2.2-new/src/abi/libgcc_eh/Makefile
+--- uClibc++-0.2.2-old/src/abi/libgcc_eh/Makefile      2007-06-04 00:51:13.000000000 +0200
++++ uClibc++-0.2.2-new/src/abi/libgcc_eh/Makefile      2007-09-03 21:51:07.000000000 +0200
+@@ -16,7 +16,7 @@
+ #
+ #else
+ #     echo Binary
+-      $(AR) x $(shell CC=$(CC) $(TOPDIR)/scripts/find_libgcc_eh.sh)
++      $(AR) x $(shell CC="$(CC)" $(TOPDIR)/scripts/find_libgcc_eh.sh)
+ #endif
+ #endif
+diff -ruN uClibc++-0.2.2-old/src/abi/libsupc/Makefile uClibc++-0.2.2-new/src/abi/libsupc/Makefile
+--- uClibc++-0.2.2-old/src/abi/libsupc/Makefile        2007-06-04 00:51:13.000000000 +0200
++++ uClibc++-0.2.2-new/src/abi/libsupc/Makefile        2007-09-03 21:51:17.000000000 +0200
+@@ -14,7 +14,7 @@
+ #
+ #else
+ #     echo Binary
+-      $(AR) x $(shell CC=$(CC) $(TOPDIR)/scripts/find_libsupc.sh)
++      $(AR) x $(shell CC="$(CC)" $(TOPDIR)/scripts/find_libsupc.sh)
+       $(RM) -f new_op*.o del_op*.o pure.o new_handler.o eh_alloc.o eh_globals.o
+ #
+ #endif