[packages] {pciutils,usbutils}: Fix updating of IDs when installing on destination...
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 17 Apr 2010 19:20:14 +0000 (19:20 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 17 Apr 2010 19:20:14 +0000 (19:20 +0000)
SVN-Revision: 20962

utils/pciutils/Makefile
utils/usbutils/Makefile

index e89faccb78b46aa4aaf211e0f85861b9a68f0706..cac5fb6d524f3228b3c218e1c5b65a61a7256722 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
 PKG_VERSION:=3.1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -34,7 +34,7 @@ endef
 
 define Package/pciutils/postinst
 #!/bin/sh
-(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids)
+(cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids)
 exit 0
 endef
 
index f15e63c2feda20f4eabbc4a24c22e48946ba22b4..15d2d5b5eed8006e28b2fc2bfbb5a669a506972a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbutils
 PKG_VERSION:=0.86
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-usb
@@ -29,7 +29,7 @@ endef
 
 define Package/usbutils/postinst
 #!/bin/sh
-(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-usbids.sh)
+(cd $${IPKG_INSTROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-usbids.sh)
 exit 0
 endef