ar71xx: add profile and generate image for the JA76PF2 board
authorGabor Juhos <juhosg@openwrt.org>
Fri, 16 Mar 2012 18:00:40 +0000 (18:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 16 Mar 2012 18:00:40 +0000 (18:00 +0000)
SVN-Revision: 30958

target/linux/ar71xx/generic/profiles/jjplus.mk
target/linux/ar71xx/image/Makefile

index eb7bd6508623d01fcb8ce15984d30450b4a76b34..3f97dbf02e873569be378be42881469cc477f4bc 100644 (file)
@@ -16,6 +16,17 @@ endef
 
 $(eval $(call Profile,JA76PF))
 
+define Profile/JA76PF2
+       NAME:=jjPlus JA76PF2
+       PACKAGES:=
+endef
+
+define Profile/JA76PF2/Description
+       Package set optimized for the jjPlus JA76PF2 board.
+endef
+
+$(eval $(call Profile,JA76PF2))
+
 define Profile/JWAP003
        NAME:=jjPlus JWAP0003
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
index 8fcaa08d1a8ead2f507e7066127ad7dd8bc08684..430e85f7d094d535e8f48e974e7ed53ddef20dfc 100644 (file)
@@ -726,6 +726,11 @@ define Image/Build/Profile/JA76PF
        $(call Image/Build/Template/$(fs_64k)/$(1),PB4X,ja76pf,$(ja76pf_cmdline))
 endef
 
+ja76pf2_cmdline=board=JA76PF2 console=ttyS0,115200
+define Image/Build/Profile/JA76PF2
+       $(call Image/Build/Template/$(fs_64k)/$(1),PB4X,ja76pf2,$(ja76pf2_cmdline))
+endef
+
 jwap003_cmdline=board=JWAP003 console=ttyS0,115200
 define Image/Build/Profile/JWAP003
        $(call Image/Build/Template/$(fs_64k)/$(1),PB4X,jwap003,$(jwap003_cmdline))
@@ -1025,6 +1030,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/FR54RTR,$(1))
        $(call Image/Build/Profile/HORNETUB,$(1))
        $(call Image/Build/Profile/JA76PF,$(1))
+       $(call Image/Build/Profile/JA76PF2,$(1))
        $(call Image/Build/Profile/JWAP003,$(1))
        $(call Image/Build/Profile/MZKW04NU,$(1))
        $(call Image/Build/Profile/MZKW300NH,$(1))