[package] collectd needs -fPIC to be passed to CFLAGS to build properly on x86_64...
authorFlorian Fainelli <florian@openwrt.org>
Sun, 18 Jan 2009 15:20:49 +0000 (15:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 18 Jan 2009 15:20:49 +0000 (15:20 +0000)
SVN-Revision: 14092

utils/collectd/Makefile

index 8ae8d1d7b893c2bc883770a247b8f90b9eebb613..44bb7f1d5e5dd8e08e3127f3029396290bf56ae7 100644 (file)
@@ -281,7 +281,7 @@ PKG_CONFIGURE_OPTS:= \
        --with-fp-layout=nothing
 
 CONFIGURE_VARS+= \
-       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS $(FPIC)" \
        KERNEL_DIR="$(LINUX_DIR)"
 
 # list of permanently disabled plugins