add a patch to use cppflags when compiling and ldflags when linking,
authorNicolas Thill <nico@openwrt.org>
Wed, 15 Mar 2006 21:41:50 +0000 (21:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 15 Mar 2006 21:41:50 +0000 (21:41 +0000)
it should prevent libtool from linking against host libraries.

SVN-Revision: 3382

openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch [new file with mode: 0644]

diff --git a/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch b/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch
new file mode 100644 (file)
index 0000000..2d14b89
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN pcre-5.0-old/Makefile.in pcre-5.0-new/Makefile.in
+--- pcre-5.0-old/Makefile.in   2004-09-13 16:20:00.000000000 +0200
++++ pcre-5.0-new/Makefile.in   2006-03-15 08:28:12.000000000 +0100
+@@ -63,6 +63,7 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
++LDFLAGS = @LDFLAGS@
+ CC_FOR_BUILD = @CC_FOR_BUILD@
+ CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
+@@ -84,10 +85,10 @@
+ # to do one or the other or both by ./configure.
+ LIBTOOL = @LIBTOOL@
+-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
++LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(CPPFLAGS) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
+ @ON_WINDOWS@LINK = $(CC) $(CFLAGS) -I. -I$(top_srcdir) -L.libs
+ @NOT_ON_WINDOWS@LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
+-LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
++LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir) $(LDFLAGS)
+ LINK_FOR_BUILD = $(LIBTOOL) --mode=link $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -I. -I$(top_srcdir)
+ # These are the version numbers for the shared libraries