mvebu: generate a single firmware for the 385-db-ap
authorImre Kaloz <kaloz@openwrt.org>
Mon, 13 Apr 2015 12:06:56 +0000 (12:06 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 13 Apr 2015 12:06:56 +0000 (12:06 +0000)
This has been done without having a board, but should work.

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 45412

target/linux/mvebu/image/Makefile

index 443110113cbcdf7831e110a8aa74b5c926f246e6..191dc27a007527b0fb5e8b417acccbd1185e1755 100644 (file)
@@ -154,6 +154,15 @@ define Image/Build/Profile/Mamba/squashfs
        ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
 endef
 
+define Image/Build/Profile/385-DB-AP/squashfs
+       $(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
+       ( \
+               dd if=$(KDIR)/uImage-armada-385-db-ap bs=8M conv=sync; \
+               dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-ubinized.bin \
+               bs=4096 conv=sync; \
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
+endef
+
 # The Default profile should build everything
 $(eval $(call MultiProfile,Default,$(PROFILES_LIST)))