add dropbear host keys to conffiles
authorFelix Fietkau <nbd@openwrt.org>
Fri, 15 Jun 2007 23:46:30 +0000 (23:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 15 Jun 2007 23:46:30 +0000 (23:46 +0000)
SVN-Revision: 7642

package/dropbear/Makefile

index 25a0cd0f55cf36cc366132c44ecf85c335d1e7ee..60625947af3a9d5e0afe14c46a8059905191bf0c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=0.49
 
 PKG_NAME:=dropbear
 PKG_VERSION:=0.49
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/ \
@@ -86,6 +86,9 @@ define Package/dropbear/install
        $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
        $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
+       $(INSTALL_DIR) $(1)/usr/lib/ipkg/info
+       echo /etc/dropbear/dropbear_rsa_host_key > $(1)/usr/lib/ipkg/info/dropbear.conffiles
+       echo /etc/dropbear/dropbear_dss_host_key >> $(1)/usr/lib/ipkg/info/dropbear.conffiles
 endef
 
 define Package/dropbearconvert/install
 endef
 
 define Package/dropbearconvert/install