[packages] ffmpeg: update to 0.5.2
authorNicolas Thill <nico@openwrt.org>
Wed, 16 Jun 2010 18:19:46 +0000 (18:19 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 16 Jun 2010 18:19:46 +0000 (18:19 +0000)
 * add OSS demuxer & PCM signed 16-bit encoder/decoder for audio output
 * add an FFMPEG_PATENTED config item to include support for patented codecs - need help to spot them
 * fix IPv6 support

SVN-Revision: 21816

multimedia/ffmpeg/Config.in
multimedia/ffmpeg/Makefile
multimedia/ffmpeg/patches/010-fix-pkg-config-files.patch [deleted file]

index d2cd36cd17bf36f07551f2c1abbd0c9cf2e13c9e..889cf8b21b72f9a555c458c6e90545c9bdf50ae1 100644 (file)
@@ -1,17 +1,23 @@
+menu "Configuration"
+       depends PACKAGE_libffmpeg
 
-# FFmpeg configuration
+config FFMPEG_IPV6
+       bool "Enable IPv6"
+       default IPV6
 
-if PACKAGE_libffmpeg
+config FFMPEG_PATENTED
+       bool "Include patented codecs and technologies"
+       default BUILD_PATENTED
 
 config FFMPEG_FFSERVER_SUPPORT
-       bool
+       bool "Include support for FFmpeg streaming support"
        select FFMPEG_MUXER_ffm
        select FFMPEG_DEMUXER_rtsp
        select FFMPEG_PROTOCOL_rtp
 
 config FFMPEG_LIBDLNA_SUPPORT
-       bool
-       default y if PACKAGE_libdlna
+       bool "Include support for libdlna/ushare"
+       depends FFMPEG_PATENTED
        select FFMPEG_DECODER_ac3
        select FFMPEG_DECODER_atrac3
        select FFMPEG_DECODER_h264
@@ -33,235 +39,212 @@ config FFMPEG_LIBDLNA_SUPPORT
 comment "Encoders ---"
 
 config FFMPEG_ENCODER_ac3
-       bool
-       prompt "AC3"
+       bool "AC3"
+       depends FFMPEG_PATENTED
        select FFMPEG_PARSER_ac3
 
 config FFMPEG_ENCODER_jpegls
-       bool
-       prompt "JPEG-LS"
+       bool "JPEG-LS"
 
 config FFMPEG_ENCODER_mpeg1video
-       bool
-       prompt "MPEG-1 Video"
+       bool "MPEG-1 Video"
 
 config FFMPEG_ENCODER_mpeg2video
-       bool
-       prompt "MPEG-2 Video"
+       bool "MPEG-2 Video"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_ENCODER_mpeg4
-       bool
-       prompt "MPEG-4"
+       bool "MPEG-4"
+       depends FFMPEG_PATENTED
+
+config FFMPEG_ENCODER_pcm_s16be
+       bool "PCM signed 16-bit big-endian"
+
+config FFMPEG_ENCODER_pcm_s16le
+       bool "PCM signed 16-bit little-endian"
 
 config FFMPEG_ENCODER_png
-       bool
-       prompt "PNG"
+       bool "PNG"
        select FFMPEG_ENCODER_zlib
 
 config FFMPEG_ENCODER_zlib
-       bool
-       prompt "Zlib"
+       bool "Zlib"
 
 comment "Decoders ---"
 
 config FFMPEG_DECODER_ac3
-       bool
-       prompt "AC3"
+       bool "AC3"
+       depends FFMPEG_PATENTED
        select FFMPEG_PARSER_ac3
 
 config FFMPEG_DECODER_atrac3
-       bool
-       prompt "ATRAC3"
+       bool "ATRAC3"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_gif
-       bool
-       prompt "GIF"
+       bool "GIF"
 
 config FFMPEG_DECODER_h264
-       bool
-       prompt "H.264"
-       select FFMPEG_PARSER_h264
+       bool "H.264"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_jpegls
-       bool
-       prompt "JPEG-LS"
+       bool "JPEG-LS"
 
 config FFMPEG_DECODER_mp3
-       bool
-       prompt "MP3"
-       select FFMPEG_PARSER_mpegaudio
+       bool "MP3"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_mpegvideo
-       bool
-       prompt "MPEG Video"
+       bool "MPEG Video"
 
 config FFMPEG_DECODER_mpeg1video
-       bool
-       prompt "MPEG-1 Video"
+       bool "MPEG-1 Video"
 
 config FFMPEG_DECODER_mpeg2video
-       bool
-       prompt "MPEG-2 Video"
+       bool "MPEG-2 Video"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_mpeg4
-       bool
-       prompt "MPEG-4"
+       bool "MPEG-4"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_mpeg4aac
-       bool
-       prompt "MPEG-4 (AAC)"
+       bool "MPEG-4 (AAC)"
+       depends FFMPEG_PATENTED
+
+config FFMPEG_DECODER_pcm_s16be
+       bool "PCM signed 16-bit big-endian"
+
+config FFMPEG_DECODER_pcm_s16le
+       bool "PCM signed 16-bit little-endian"
 
 config FFMPEG_DECODER_png
-       bool
-       prompt "PNG"
+       bool "PNG"
        select FFMPEG_DECODER_zlib
 
 config FFMPEG_DECODER_wmav1
-       bool
-       prompt "WMAv1"
+       bool "WMAv1"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_wmav2
-       bool
-       prompt "WMAv2"
+       bool "WMAv2"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_zlib
-       bool
-       prompt "Zlib"
+       bool "Zlib"
 
 comment "Muxers ---"
 
 config FFMPEG_MUXER_ac3
-       bool
-       prompt "AC3"
-       select FFMPEG_PARSER_ac3
+       bool "AC3"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_MUXER_ffm
-       bool
-       prompt "FFM (ffserver live feed)"
+       bool "FFM (ffserver live feed)"
 
 config FFMPEG_MUXER_h264
-       bool
-       prompt "H.264"
-       select FFMPEG_PARSER_h264
+       bool "H.264"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_MUXER_mp3
-       bool
-       prompt "MP3"
+       bool "MP3"
 
 config FFMPEG_MUXER_mp4
-       bool
-       prompt "MP4"
+       bool "MP4"
 
 config FFMPEG_MUXER_mpeg1video
-       bool
-       prompt "MPEG-1 Video"
+       bool "MPEG-1 Video"
 
 config FFMPEG_MUXER_mpeg2video
-       bool
-       prompt "MPEG-2 Video"
+       bool "MPEG-2 Video"
 
 config FFMPEG_MUXER_mpegts
-       bool
-       prompt "MPEG-2 (TS)"
+       bool "MPEG-2 (TS)"
+
+config FFMPEG_MUXER_oss
+       bool "OSS (Open Sound System playback)"
 
 config FFMPEG_MUXER_rtp
-       bool
-       prompt "RTP"
+       bool "RTP"
 
 comment "Demuxers ---"
 
 config FFMPEG_DEMUXER_ac3
-       bool
-       prompt "AC3"
-       select FFMPEG_PARSER_ac3
+       bool "AC3"
 
 config FFMPEG_DEMUXER_ffm
-       bool
-       prompt "FFM (ffserver live feed)"
+       bool "FFM (ffserver live feed)"
 
 config FFMPEG_DEMUXER_h264
-       bool
-       prompt "H.264"
-       select FFMPEG_PARSER_h264
+       bool "H.264"
+       depends FFMPEG_PATENTED
 
 config FFMPEG_DEMUXER_mp3
-       bool
-       prompt "MP3"
+       bool "MP3"
 
 config FFMPEG_DEMUXER_mpegvideo
-       bool
-       prompt "MPEG Video"
-       select FFMPEG_PARSER_mpegvideo
+       bool "MPEG Video"
 
 config FFMPEG_DEMUXER_mpegps
-       bool
-       prompt "MPEG-2 (PS)"
+       bool "MPEG-2 (PS)"
 
 config FFMPEG_DEMUXER_mpegts
-       bool
-       prompt "MPEG-2 (TS)"
+       bool "MPEG-2 (TS)"
+
+config FFMPEG_DEMUXER_rm
+       bool "RM"
+       help
+         RealMedia format demuxer
 
 config FFMPEG_DEMUXER_rtsp
-       bool
-       prompt "RTSP"
+       bool "RTSP"
+       select FFMPEG_DEMUXER_rm
        select FFMPEG_DEMUXER_sdp
 
 config FFMPEG_DEMUXER_sdp
-       bool
-       prompt "SDP"
+       bool "SDP"
        select FFMPEG_DEMUXER_mpegts
 
 comment "Parsers ---"
 
 config FFMPEG_PARSER_ac3
-       bool
-       prompt "AC3"
+       bool "AC3"
 
 config FFMPEG_PARSER_h264
-       bool
-       prompt "H.264"
+       bool "H.264"
+       depends FFMPEG_PATENTED
+       select FFMPEG_DECODER_h264
 
 config FFMPEG_PARSER_mpegaudio
-       bool
-       prompt "MPEG Audio"
+       bool "MPEG Audio"
 
 config FFMPEG_PARSER_mpegvideo
-       bool
-       prompt "MPEG Video"
+       bool "MPEG Video"
 
 config FFMPEG_PARSER_mpeg4video
-       bool
-       prompt "MPEG-4 Video"
+       bool "MPEG-4 Video"
 
 comment "Protocols ---"
 
 config FFMPEG_PROTOCOL_file
-       bool
-       prompt "file:"
+       bool "file:"
 
 config FFMPEG_PROTOCOL_http
-       bool
-       prompt "http:"
+       bool "http:"
 
 config FFMPEG_PROTOCOL_pipe
-       bool
-       prompt "pipe:"
+       bool "pipe:"
 
 config FFMPEG_PROTOCOL_rtp
-       bool
-       prompt "rtp:"
+       bool "rtp:"
        select FFMPEG_PROTOCOL_udp
 
 config FFMPEG_PROTOCOL_tcp
-       bool
-       prompt "tcp:"
+       bool "tcp:"
 
 config FFMPEG_PROTOCOL_udp
-       bool
-       prompt "udp:"
+       bool "udp:"
 
-config FFMPEG_PROTOCOL_IPv6
-       bool
-       prompt "IPv6"
+endmenu
 
-endif
index 05136af11672093ef83982173bddd343567dcc66..718a839d2b047077782cc5c56a3e666fd6fa8ba9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
-PKG_VERSION:=20080419
-PKG_RELEASE:=2
+PKG_VERSION:=0.5.2
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-export-snapshot-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_MD5SUM:=63aeb859941b96ed3ef7b0c7a643bf4d
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-export-2008-04-19
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://ffmpeg.org/releases/
+PKG_MD5SUM:=
 
 FFMPEG_ENCODERS:= \
        ac3 \
@@ -23,6 +21,8 @@ FFMPEG_ENCODERS:= \
        mpeg1video \
        mpeg2video \
        mpeg4 \
+       pcm_s16be \
+       pcm_s16le \
        png \
        zlib \
 
@@ -38,6 +38,8 @@ FFMPEG_DECODERS:= \
        mpeg4 \
        mpeg4aac \
        mpegvideo \
+       pcm_s16be \
+       pcm_s16le \
        png \
        wmav1 \
        wmav2 \
@@ -52,6 +54,7 @@ FFMPEG_MUXERS:= \
        mpeg1video \
        mpeg2video \
        mpegts \
+       oss \
        rtp \
 
 FFMPEG_DEMUXERS:= \
@@ -62,6 +65,7 @@ FFMPEG_DEMUXERS:= \
        mpegps \
        mpegts \
        mpegvideo \
+       rm \
        rtsp \
        sdp \
        v4l2 \
@@ -129,7 +133,7 @@ $(call Package/ffmpeg/Default)
  SECTION:=libs
  CATEGORY:=Libraries
  TITLE+= libraries
- DEPENDS+= +libpthread +libfaad2 +zlib
+ DEPENDS+= +libpthread +zlib
  MENU:=1
 endef
 
@@ -184,7 +188,7 @@ define Build/Configure
                --enable-ffmpeg \
                --enable-ffserver \
                --enable-gpl \
-               --enable-libfaad \
+               --disable-libfaad \
                --disable-mmx \
                --disable-mmx2 \
                --enable-pthreads \
@@ -195,6 +199,10 @@ define Build/Configure
                --enable-zlib \
                --enable-postproc \
                \
+               $(if $(CONFIG_FFMPEG_IPV6),,--disable-ipv6) \
+               \
+               --disable-bsfs \
+               --disable-devices \
                --disable-encoders \
                $(FFMPEG_CONFIGURE_ENCODERS) \
                --disable-decoders \
@@ -205,7 +213,6 @@ define Build/Configure
                $(FFMPEG_CONFIGURE_DEMUXERS) \
                --disable-parsers \
                $(FFMPEG_CONFIGURE_PARSERS) \
-               --disable-bsfs \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS) \
        )
diff --git a/multimedia/ffmpeg/patches/010-fix-pkg-config-files.patch b/multimedia/ffmpeg/patches/010-fix-pkg-config-files.patch
deleted file mode 100644 (file)
index faefee1..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -881,11 +881,11 @@ logfile="config.err"
- # installation paths
- prefix="/usr/local"
--libdir='$(PREFIX)/lib'
-+libdir='${prefix}/lib'
- shlibdir="$libdir"
--incdir='$(PREFIX)/include'
--mandir='$(PREFIX)/share/man'
--bindir='$(PREFIX)/bin'
-+incdir='${prefix}/include'
-+mandir='${prefix}/share/man'
-+bindir='${prefix}/bin'
- # toolchain
- cc="gcc"
-@@ -1936,8 +1936,7 @@ echo "#ifndef FFMPEG_CONFIG_H" >> $TMPH
- echo "#define FFMPEG_CONFIG_H" >> $TMPH
- echo "#define FFMPEG_CONFIGURATION \"$FFMPEG_CONFIGURATION\"" >> $TMPH
--echo "PREFIX=$prefix" >> config.mak
--echo "prefix=\$(DESTDIR)\$(PREFIX)" >> config.mak
-+echo "prefix=$prefix" >> config.mak
- echo "LIBDIR=\$(DESTDIR)$libdir" >> config.mak
- echo "SHLIBDIR=\$(DESTDIR)$shlibdir" >> config.mak
- echo "INCDIR=\$(DESTDIR)$incdir" >> config.mak