install missing ebtables files
authorFelix Fietkau <nbd@openwrt.org>
Fri, 9 Jun 2006 02:05:53 +0000 (02:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 9 Jun 2006 02:05:53 +0000 (02:05 +0000)
SVN-Revision: 3923

openwrt/package/ebtables/Makefile

index 952ac29dd89f22dcecf0a36ae8f2f98790e9c644..dae932ea842ac07dab91eea39237cfde328f4c30 100644 (file)
@@ -29,7 +29,13 @@ $(PKG_BUILD_DIR)/.built:
 $(IPKG_EBTABLES):
        install -d -m0755 $(IDIR_EBTABLES)/etc
        install -m0644 $(PKG_BUILD_DIR)/ethertypes $(IDIR_EBTABLES)/etc/
+       install -d -m0755 $(IDIR_EBTABLES)/usr/lib
+       install -m0755 $(PKG_BUILD_DIR)/lib*.so $(IDIR_EBTABLES)/usr/lib/
+       install -d -m0755 $(IDIR_EBTABLES)/usr/lib/ebtables
+       install -m0755 $(PKG_BUILD_DIR)/extensions/*.so $(IDIR_EBTABLES)/usr/lib/ebtables/
        install -d -m0755 $(IDIR_EBTABLES)/usr/sbin
        install -m0755 $(PKG_BUILD_DIR)/ebtables $(IDIR_EBTABLES)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-save $(IDIR_EBTABLES)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/ebtables-restore $(IDIR_EBTABLES)/usr/sbin/
        $(RSTRIP) $(IDIR_EBTABLES)
        $(IPKG_BUILD) $(IDIR_EBTABLES) $(PACKAGE_DIR)