ctorrent:
authorOliver Ertl <oliver@ertl-net.net>
Sun, 30 Sep 2007 19:48:02 +0000 (19:48 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Sun, 30 Sep 2007 19:48:02 +0000 (19:48 +0000)
 * Add libtool fixes
 * Use the g++-uc wrapper the right way (thanks nico)

SVN-Revision: 9080

net/ctorrent/Makefile

index be3d066014558871551dbfccd6694d3ec0d3047f..ea85c71bf315e35c324168415fae30aff2535dd8 100644 (file)
@@ -35,7 +35,18 @@ endef
    
 CONFIGURE_VARS += \
        CXX="g++-uc" \
-       CXXFLAGS="$$$$CXX_CFLAGS -fno-rtti" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
+
+define Build/Configure
+       $(call Build/Configure/Default,)
+       $(call libtool_disable_rpath)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
 
 define Package/ctorrent/install        
        $(INSTALL_DIR) $(1)/usr/bin