[package] gdb: fix gdbserver subpackage, cleanup
authorNicolas Thill <nico@openwrt.org>
Mon, 23 Feb 2009 23:58:07 +0000 (23:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 23 Feb 2009 23:58:07 +0000 (23:58 +0000)
SVN-Revision: 14649

package/gdb/Makefile

index 9b65ffcecba9c3b7327c47b24e7558b664f81585..c2fc2e97b3926eed673e2ef600def2b109ae5d0d 100644 (file)
@@ -12,9 +12,8 @@ PKG_VERSION:=6.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/gdb
 PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
 PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
-PKG_CAT:=bzcat
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -40,11 +39,11 @@ define Package/gdbserver/description
  than the one which is running the program being debugged.
 endef
 
  than the one which is running the program being debugged.
 endef
 
-TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include
-TARGET_LDFLAGS += -L$(STAGING_DIR)/usr/lib
-CONFIGURE_ARGS += --with-system-readline
+CONFIGURE_ARGS+= \
+       --with-system-readline
 
 
-export ac_cv_search_tgetent=$(TARGET_LDFLAGS) -lncurses -lreadline
+CONFIGURE_VARS+= \
+       ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -60,7 +59,7 @@ endef
 
 define Package/gdbserver/install       
        $(INSTALL_DIR) $(1)/usr/bin
 
 define Package/gdbserver/install       
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gdb))
 endef
 
 $(eval $(call BuildPackage,gdb))