kernel/modules: add kmod-crypto-hw-ccp
authorFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 10:06:43 +0000 (10:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 10:06:43 +0000 (10:06 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 48347

package/kernel/linux/modules/crypto.mk

index 7c710531cc04f322254fbc96f827dc594a321bc8..99fb5a0e25ea228b70bb9980fce028799d76caec 100644 (file)
@@ -177,6 +177,24 @@ endef
 $(eval $(call KernelPackage,crypto-hw-padlock))
 
 
 $(eval $(call KernelPackage,crypto-hw-padlock))
 
 
+define KernelPackage/crypto-hw-ccp
+  TITLE:=AMD Cryptographic Coprocessor
+  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core
+  KCONFIG:= \
+       CONFIG_CRYPTO_HW=y \
+       CONFIG_CRYPTO_DEV_CCP=y \
+       CONFIG_CRYPTO_DEV_CCP_CRYPTO \
+       CONFIG_CRYPTO_DEV_CCP_DD
+  FILES:= \
+       $(LINUX_DIR)/drivers/crypto/ccp/ccp.ko \
+       $(LINUX_DIR)/drivers/crypto/ccp/ccp-crypto.ko
+  AUTOLOAD:=$(call AutoLoad,09,ccp ccp-crypto)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ccp))
+
+
 define KernelPackage/crypto-hw-geode
   TITLE:=AMD Geode hardware crypto module
   DEPENDS:=+kmod-crypto-manager
 define KernelPackage/crypto-hw-geode
   TITLE:=AMD Geode hardware crypto module
   DEPENDS:=+kmod-crypto-manager