fix rrdtool compile
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 May 2009 15:21:38 +0000 (15:21 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 May 2009 15:21:38 +0000 (15:21 +0000)
SVN-Revision: 15590

libs/rrdtool-1.0.x/Makefile
libs/rrdtool-1.0.x/patches/002-no_timezone.patch [new file with mode: 0644]

index cb9c25f531ce94713ea357b31a50d5523fa2431c..af19bd5bcf60f8b6a3887528084d72240e29ea89 100644 (file)
@@ -97,7 +97,7 @@ Round Robin Database (RRD) management tools.
        This package contains command line tools used to manage RRDs.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) --std=c99
 
 CONFIGURE_ARGS += \
        $(DISABLE_LARGEFILE) \
diff --git a/libs/rrdtool-1.0.x/patches/002-no_timezone.patch b/libs/rrdtool-1.0.x/patches/002-no_timezone.patch
new file mode 100644 (file)
index 0000000..07564b4
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/src/rrd_tool.c
++++ b/src/rrd_tool.c
+@@ -225,11 +225,8 @@
+         struct rusage  myusage;
+         struct timeval starttime;
+         struct timeval currenttime;
+-        struct timezone tz;
+-          tz.tz_minuteswest =0;
+-          tz.tz_dsttime=0;
+-          gettimeofday(&starttime,&tz);
++          gettimeofday(&starttime,NULL);
+ #endif
+           while (fgets(aLine, sizeof(aLine)-1, stdin)){
+@@ -252,7 +249,7 @@
+ #if HAVE_GETRUSAGE
+               getrusage(RUSAGE_SELF,&myusage);
+-              gettimeofday(&currenttime,&tz);
++              gettimeofday(&currenttime,NULL);
+               printf("OK u:%1.2f s:%1.2f r:%1.2f\n",
+                      (double)myusage.ru_utime.tv_sec+
+                      (double)myusage.ru_utime.tv_usec/1000000.0,