[package] update amule to 2.2.5 (#3788)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 27 Sep 2009 21:19:07 +0000 (21:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 27 Sep 2009 21:19:07 +0000 (21:19 +0000)
SVN-Revision: 17773

net/amule/Makefile
net/amule/patches/001-no_backtrace.patch
net/amule/patches/010-fix-gcc_4_3-compile.patch [deleted file]

index 1d391e5f6bd845830ee63da8745acd0548df668c..830b4947341d256ea79c0ac4c1c28ff6550360a6 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aMule
-PKG_VERSION:=2.1.3
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/amule
-PKG_MD5SUM:=0aafdd159edb8ad5f0064da87998b47d
+PKG_MD5SUM:=
 
 PKG_BUILD_DEPENDS:=libgd
 
@@ -25,7 +25,7 @@ define Package/amule
   CATEGORY:=Network
   TITLE:=A multi-platform eMule-like ed2k client
   URL:=http://www.amule.org/
-  DEPENDS:=+libpng +libpthread +libncurses +libreadline +libwxbase
+  DEPENDS:=+libpng +libpthread +libncurses +libreadline +libwxbase +libcryptoxx
 endef
 
 CONFIGURE_ARGS+= \
@@ -54,12 +54,13 @@ CONFIGURE_ARGS+= \
        --enable-embedded-crypto \
        --enable-gsocket \
        --disable-gtktest \
+       --disable-crypto \
        \
        --with-zlib="$(STAGING_DIR)/usr" \
        --with-gdlib-prefix="$(STAGING_DIR)/usr" \
        --with-libpng-prefix="$(STAGING_DIR)/usr" \
        --with-wx-prefix="$(STAGING_DIR)/usr" \
-       --without-crypto-prefix \
+       --with-crypto-prefix="$(STAGING_DIR)/usr" \
        --without-libiconv-prefix \
        --without-libintl-prefix \
        --without-x \
index 39cf32783186202249d377bc15f13a54c76825eb..f4882913791b51134628931298ec9ccb5ed499aa 100644 (file)
@@ -2,15 +2,6 @@ Index: aMule-2.1.3/src/libs/common/MuleDebug.cpp
 ===================================================================
 --- aMule-2.1.3.orig/src/libs/common/MuleDebug.cpp     2007-09-23 21:47:41.000000000 +0200
 +++ aMule-2.1.3/src/libs/common/MuleDebug.cpp  2007-09-23 21:47:41.000000000 +0200
-@@ -32,7 +32,7 @@
- #include "MuleDebug.h"                        // Interface declaration
- #include "StringFunctions.h"  // Needed for unicode2char
--#ifdef __LINUX__
-+#if defined(__LINUX__) && !defined(__UCLIBC__)
-       #include <execinfo.h>
-       #include <cxxabi.h>
-       #include <wx/thread.h>
 @@ -151,7 +151,7 @@
        return walker.m_trace;
  }
diff --git a/net/amule/patches/010-fix-gcc_4_3-compile.patch b/net/amule/patches/010-fix-gcc_4_3-compile.patch
deleted file mode 100644 (file)
index d6c6261..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/ExternalConnector.h b/src/ExternalConnector.h
-index 3d214f6..30d12a7 100644
---- a/src/ExternalConnector.h
-+++ b/src/ExternalConnector.h
-@@ -143,7 +143,7 @@ public:
-       bool Parse_Command(const wxString& buffer);
-       void GetCommand(const wxString &prompt, char* buffer, size_t buffer_size);
-       const CECPacket *SendRecvMsg_v2(const CECPacket *request) { return m_ECClient->SendRecvPacket(request); }
--      void ConnectAndRun(const wxString &ProgName, const wxString& ProgName);
-+      void ConnectAndRun(const wxString &ProgName, const wxString& ProgVersion);
-       void ShowGreet();
-       //