ar71xx: image: improve the rootfs_align macro
authorGabor Juhos <juhosg@openwrt.org>
Sun, 22 Sep 2013 09:11:24 +0000 (09:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 22 Sep 2013 09:11:24 +0000 (09:11 +0000)
Improve the macro to return correct value for
all squashfs variant.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38116

target/linux/ar71xx/image/Makefile

index 9871f6ec476cc5609d9447babb5838839ca26514..60990b284d07f361796ec5b5110e319c99c8c09c 100644 (file)
@@ -14,7 +14,7 @@ $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squ
 endef
 
 define rootfs_align
-$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs-%,0x4,$(1)))))
+$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
 endef
 
 define sysupname