nuke old libtool package - moved to trunk now
authorFelix Fietkau <nbd@openwrt.org>
Thu, 27 Dec 2007 02:11:40 +0000 (02:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 27 Dec 2007 02:11:40 +0000 (02:11 +0000)
SVN-Revision: 9945

libs/libtool/Makefile [deleted file]
libs/libtool/patches/001-force_dlopen_deplibs.patch [deleted file]

diff --git a/libs/libtool/Makefile b/libs/libtool/Makefile
deleted file mode 100644 (file)
index 67639b5..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libtool
-PKG_VERSION:=1.5.22
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/libtool
-PKG_MD5SUM:=8e0ac9797b62ba4dcc8a2fb7936412b0
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libltdl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=A generic dynamic object loading library
-  URL:=http://www.gnu.org/software/libtool/
-endef
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               libltdl/configure.ac \
-               libltdl/acinclude.m4 \
-               libltdl/aclocal.m4 \
-               libltdl/Makefile.in \
-               libltdl/config-h.in \
-               libltdl/configure \
-       );
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/libltdl/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libltdl.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libltdl))
diff --git a/libs/libtool/patches/001-force_dlopen_deplibs.patch b/libs/libtool/patches/001-force_dlopen_deplibs.patch
deleted file mode 100644 (file)
index dfcf56b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
---- libtool-1.5.14/libltdl/acinclude.m4        2005-02-12 13:20:02.000000000 +0100
-+++ libtool-1.5.14.new/libltdl/acinclude.m4    2006-04-17 23:00:24.000000000 +0200
-@@ -6228,10 +6228,8 @@
-     ;;
-   esac
-   ])
--if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
-  AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
-     [Define if the OS needs help to load dependent libraries for dlopen().])
--fi
- ])# AC_LTDL_SYS_DLOPEN_DEPLIBS