make sure quilt starts with the correct patch order in series
authorFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jun 2007 00:11:27 +0000 (00:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 18 Jun 2007 00:11:27 +0000 (00:11 +0000)
SVN-Revision: 7658

include/quilt.mk

index e02fab08798dd04d37aad7f8f0535e2d8e0d41f7..47195293e881df9b28fe9b0faa5a56956d16cc9e 100644 (file)
@@ -57,6 +57,10 @@ endef
 
 $(STAMP_PATCHED): $(STAMP_PREPARED)
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       (\
+               cd $(PKG_BUILD_DIR)/patches; \
+               find * -type f \! -name series | sort > series; \
+       )
        [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
        touch $@