openssl patches from below0
authorMike Baker <mbm@openwrt.org>
Fri, 16 Jul 2004 05:52:23 +0000 (05:52 +0000)
committerMike Baker <mbm@openwrt.org>
Fri, 16 Jul 2004 05:52:23 +0000 (05:52 +0000)
SVN-Revision: 100

obsolete-buildroot/make/openssl.mk
obsolete-buildroot/sources/libssl.control [new file with mode: 0644]
obsolete-buildroot/sources/openssl.control [new file with mode: 0644]

index a4003553b1d5779ed56a593b3dcb2ee9c980576f..0e1de34ce1ea34b9808d578a69b4261e18cb5b0e 100644 (file)
@@ -10,6 +10,9 @@ OPENSSL_SOURCE:=openssl-0.9.7d.tar.gz
 OPENSSL_DIR:=$(BUILD_DIR)/openssl-0.9.7d
 OPENSSL_PATCH=$(SOURCE_DIR)/openssl.patch
 
+OPENSSL_IPK_DIR=$(BUILD_DIR)/openssl-0.9.7d-ipk
+LIBSSL_IPK=$(BUILD_DIR)/libssl_0.9.7d_mipsel.ipk
+
 $(DL_DIR)/$(OPENSSL_SOURCE):
        $(WGET) -P $(DL_DIR) $(OPENSSL_SITE)/$(OPENSSL_SOURCE)
 
@@ -65,6 +68,18 @@ openssl-headers: $(TARGET_DIR)/usr/lib/libssl.a
 
 openssl: uclibc $(TARGET_DIR)/usr/lib/libcrypto.so.0.9.7
 
+$(LIBSSL_IPK): uclibc $(STAGING_DIR)/usr/lib/libcrypto.so.0.9.7
+       mkdir -p $(OPENSSL_IPK_DIR)/CONTROL
+       cp $(SOURCE_DIR)/libssl.control $(OPENSSL_IPK_DIR)/CONTROL/control
+       mkdir -p $(OPENSSL_IPK_DIR)/usr/lib
+       cp -fa $(STAGING_DIR)/lib/libcrypto.so* $(OPENSSL_IPK_DIR)/usr/lib/
+       cp -fa $(STAGING_DIR)/lib/libssl.so* $(OPENSSL_IPK_DIR)/usr/lib/
+       -$(STRIP) --strip-unneeded $(OPENSSL_IPK_DIR)/usr/lib/libssl.so.0.9.7
+       -$(STRIP) --strip-unneeded $(OPENSSL_IPK_DIR)/usr/lib/libcrypto.so.0.9.7
+       cd $(BUILD_DIR); $(STAGING_DIR)/bin/ipkg-build -c -o root -g root $(OPENSSL_IPK_DIR)
+
+openssl-ipk: $(LIBSSL_IPK)
+
 openssl-source: $(DL_DIR)/$(OPENSSL_SOURCE)
 
 openssl-clean: 
diff --git a/obsolete-buildroot/sources/libssl.control b/obsolete-buildroot/sources/libssl.control
new file mode 100644 (file)
index 0000000..4fe0b87
--- /dev/null
@@ -0,0 +1,9 @@
+Package: libssl
+Priority: optional
+Version: 0.9.7d-1
+Architecture: mipsel
+Maintainer: below0
+Section: libs
+Source: Embedded in the main OpenWrt buildroot
+Description: OpenSSL libraries used for SSL encryption.
+
diff --git a/obsolete-buildroot/sources/openssl.control b/obsolete-buildroot/sources/openssl.control
new file mode 100644 (file)
index 0000000..cc679a6
--- /dev/null
@@ -0,0 +1,9 @@
+Package: openssl
+Priority: optional
+Version: 0.9.7d-1
+Architecture: mipsel
+Maintainer: below0
+Section: libs
+Source: Embedded in the main OpenWrt buildroot
+Description: OpenSSL libraries used for SSL encryption.
+