petitboot: Automate PACKAGE_VERSION
authorGeoff Levand <geoffrey.levand@am.sony.com>
Wed, 26 Aug 2009 22:09:23 +0000 (22:09 +0000)
committerGeoff Levand <geoffrey.levand@am.sony.com>
Wed, 26 Aug 2009 22:09:23 +0000 (22:09 +0000)
Make a default petitboot PACKAGE_VERSION based on
the build machine HOSTNAME and the date.

Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
SVN-Revision: 17414

utils/petitboot/Makefile

index d4cdeae44e0723fce7890283c9c1100b69641dcf..9022c1f232315431a23de9f1e2a2d45efbf5e376 100644 (file)
@@ -70,7 +70,8 @@ petitboot-install-autorun-$(CONFIG_PETITBOOT_AUTORUN_CUI) = \
 petitboot-install-autorun-$(CONFIG_PETITBOOT_AUTORUN_GUI) = \
        ln -sf pb-twin $(1)/usr/sbin/petitboot
 
-CONFIGURE_ARGS += $(petitboot-config-args-y)
+CONFIGURE_ARGS += $(petitboot-config-args-y) \
+       PACKAGE_VERSION=$(shell echo ${HOSTNAME})-$(shell date +%y.%m.%d-%H.%M)
 
 EXTRA_CPPFLAGS += $(petitboot-cppflags-y)