[package] update coreutils to 7.2 (#4871)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Apr 2009 13:08:10 +0000 (13:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Apr 2009 13:08:10 +0000 (13:08 +0000)
SVN-Revision: 15102

utils/coreutils/Makefile
utils/coreutils/patches/001-no_docs_man_tests.patch

index 0c7e95b84157371d43c7d70efc9ab227c473ae3b..ce88452817bed30e3eb857ae5af4f02afb21bf3b 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coreutils
-PKG_VERSION:=6.9
+PKG_VERSION:=7.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/coreutils/
-PKG_MD5SUM:=c9607d8495f16e98906e7ed2d9751a06
+PKG_MD5SUM:=427c2914d3eab956f317c9ec6a45e62a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,11 +31,14 @@ define Package/coreutils/description
         sufficient and much smaller.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-install-program=su
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                SHELL="/bin/bash" \
-               all install
+               all install install-root
 endef
 
 define Package/coreutils/install
index faaeb864141a66d0310e3dd0e135617259545a67..4b3558de4449283b95e31bf08da8c4ea6b6134f1 100644 (file)
@@ -1,24 +1,24 @@
 diff -urN coreutils-6.9/Makefile.am coreutils-6.9.new/Makefile.am
 --- coreutils-6.9/Makefile.am  2007-03-18 22:36:43.000000000 +0100
 +++ coreutils-6.9.new/Makefile.am      2008-11-15 14:15:17.000000000 +0100
-@@ -17,7 +17,7 @@
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
- # 02110-1301, USA.
+@@ -15,7 +15,7 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program.  If not, see <http://www.gnu.org/licenses/>.
  
--SUBDIRS = lib src doc man po tests
+-SUBDIRS = lib src doc man po tests gnulib-tests
 +SUBDIRS = lib src po
- EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
-   .gitignore \
-   .hgignore \
+ EXTRA_DIST = cfg.mk maint.mk \
+   .prev-version THANKS-to-translators THANKStt.in \
+   .version \
 diff -urN coreutils-6.9/Makefile.in coreutils-6.9.new/Makefile.in
 --- coreutils-6.9/Makefile.in  2007-03-22 22:20:26.000000000 +0100
 +++ coreutils-6.9.new/Makefile.in      2008-11-15 14:15:05.000000000 +0100
-@@ -520,7 +520,7 @@
- target_alias = @target_alias@
+@@ -918,7 +918,7 @@
+ top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
--SUBDIRS = lib src doc man po tests
-+SUBDIRS = lib src po 
- EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
-   .gitignore \
-   .hgignore \
+-SUBDIRS = lib src doc man po tests gnulib-tests
++SUBDIRS = lib src po
+ EXTRA_DIST = cfg.mk maint.mk \
+   .prev-version THANKS-to-translators THANKStt.in \
+   .version \