[package] pptp: support interface sections without ifname by implementing scan_pptp()
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 28 May 2010 00:30:09 +0000 (00:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 28 May 2010 00:30:09 +0000 (00:30 +0000)
SVN-Revision: 21590

package/pptp/Makefile
package/pptp/files/pptp.sh

index 018e9b570e403601fa426d017ccfcf31e0948e80..a55309bf51a5889728d90117d81ebb9f3b257209 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptp
 PKG_VERSION:=1.7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/pptpclient
index c95895d9fa7c0d746537eaa54fdc5cdda16211b7..436bee3c8763dd79c474cede47ef14181365feb8 100644 (file)
@@ -2,6 +2,10 @@ find_gw() {
        route -n | awk '$1 == "0.0.0.0" { print $2; exit }'
 }
 
+scan_pptp() {
+       config_set "$1" device "pptp-$1"
+}
+
 stop_interface_pptp() {
        stop_interface_ppp "$1"
 }